Win a copy of Microservices Testing (Live Project) this week in the Spring forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Tim Cooke
  • Ron McLeod
  • Jeanne Boyarsky
  • Paul Clapham
Sheriffs:
  • Liutauras Vilda
  • Henry Wong
  • Devaka Cooray
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • Al Hobbs
  • Carey Brown
Bartenders:
  • Piet Souris
  • Mikalai Zaikin
  • Himai Minh

Tomcat 6.0.30: cannot deploy application: access denied.

 
Ranch Hand
Posts: 93
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Guys,
please help me to solve this issue. I have installed Tomcat 6.0.30 and encountered some new features compared to 6.0.20: new roles. I have created admin role in tomcat-users:


<role rolename="manager-gui"/>
<role rolename="manager-script"/>
<role rolename="manager-jmx"/>
<role rolename="manager-status"/>
<user username="admin" password="Password" roles="manager-gui, manager-script, manager-jmx, manager-status"/>
</tomcat-users>



I CAN access the manager application. But I cannot deploy any application from it! When I try to deploy application it throws 403 Access Denied page. Whats wrong?
 
Rancher
Posts: 618
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
According to the documentation:

Apache Tomcat 6.0 Realm Configuration HOW-TO wrote:If you wish to use the Manager Application to deploy and undeploy applications in a running Tomcat 6 installation, you MUST add the "manager" role to at least one username in your selected Realm implementation. This is because the manager web application itself uses a security constraint that requires role "manager" to access ANY request URI within that application.

 
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi,

Were you able to get this working? I am running into the same issue here since trying to use 6.0.30+ versions to tomcat.

I can access the manager application but if I try to deploy a warfile, we get the 403 page. I have tried many possible combinations of roles including the old "manager" role and all the new "manager-*" roles with no success. I did notice that if I deploy a warfile using the "WAR file to deploy" option it works fine. Unfortunately for our application we need to specify a context path and xml configuration file, so we need to use the "Deploy directory or WAR file located on server" deploy.
 
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Same problem here.
In my case, we can't make it work even with the "WAR file to deploy" option. I've tried everything I could think of, but we're just stuck.
 
Greenhorn
Posts: 1
IntelliJ IDE Tomcat Server
  • Likes 1
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I faced the same issue, then I saw https://issues.apache.org/bugzilla/show_bug.cgi?id=51147

The issue is that the Tomcat Manager form submission needs to be via a POST rather than GET.

Using Google Chrome, an Inspect Element, followed by an Edit Attribute on the form method attribute fixed it for me.
 
Greenhorn
Posts: 3
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator

Rishi Deshpande wrote:I faced the same issue, then I saw https://issues.apache.org/bugzilla/show_bug.cgi?id=51147

The issue is that the Tomcat Manager form submission needs to be via a POST rather than GET.

Using Google Chrome, an Inspect Element, followed by an Edit Attribute on the form method attribute fixed it for me.


It's work.
Thank you!
 
reply
    Bookmark Topic Watch Topic
  • New Topic