Win a copy of Terraform in Action this week in the Cloud forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Tim Cooke
  • Campbell Ritchie
  • Paul Clapham
  • Ron McLeod
  • Liutauras Vilda
Sheriffs:
  • Jeanne Boyarsky
  • Rob Spoor
  • Bear Bibeault
Saloon Keepers:
  • Jesse Silverman
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • Carey Brown
Bartenders:
  • Piet Souris
  • Al Hobbs
  • salvin francis

Refactor Managed Bean

 
Greenhorn
Posts: 13
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi Everyone,

I am new at JSF and I am puzzled as to why when I refactor my backing bean, my JSF doesn't work anymore. Let me explain with code.


Everything works fine. When I run it, my browser displays "Hello World!" The minute I refactor (rename) Hello class to HelloTest and change hello.world (in my beanhello.xhtml) to hellotest.world, it doesn't work when I run it again. My browser display a blank page. I stopped and started the server, rebuild, redeploy and nothing works.

What am I doing incorrectly?

Thank you in advance.

Gregg
 
Ranch Hand
Posts: 32
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
If the new refactored Managed Bean name is HelloTest, you should call it from helloTest from the page, not hellotest. That should work.
 
Gallen Thomas
Greenhorn
Posts: 13
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator

Daniel Del Moral wrote:If the new refactored Managed Bean name is HelloTest, you should call it from helloTest from the page, not hellotest. That should work.



Ah yes, thank you Daniel! It works.
 
reply
    Bookmark Topic Watch Topic
  • New Topic