• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Jeanne Boyarsky
  • Ron McLeod
  • Paul Clapham
  • Liutauras Vilda
Sheriffs:
  • paul wheaton
  • Rob Spoor
  • Devaka Cooray
Saloon Keepers:
  • Stephan van Hulst
  • Tim Holloway
  • Carey Brown
  • Frits Walraven
  • Tim Moores
Bartenders:
  • Mikalai Zaikin

Running a script on a windows machine and on the Unix machine

 
Ranch Hand
Posts: 60
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
hello I am running a script that has the following:

JAVA_OPTS="-Xrunjdwp:transport=dt_socket,address=9090,server=y,suspend=n"
JAVA_OPTS="$JAVA_OPTS -Dcom.sun.management.jmxremote.port=7555 -Dcom.sun.management.jmxremote.password=false -Dcom.sun.management.jmxremote.authenticate=false -Dcom.sun.management.jmxremote.ssl=false"

This is used to set the remote debugging and JMX monitoring on the server.

When I set this on a windows machine:

set JAVA_OPTS="-Xrunjdwp:transport=dt_socket,address=9090,server=y,suspend=n"
set JAVA_OPTS=$JAVA_OPTS "-Dcom.sun.management.jmxremote.port=7555" "-Dcom.sun.management.jmxremote.password=false"
"-Dcom.sun.management.jmxremote.authenticate=false" "-Dcom.sun.management.jmxremote.ssl=false"

This works fine, when I run multiple scripts that use JAVA_OPTS.

But when I run the same on a Unix machine I get an error like:

ERROR: transport error 202: bind failed: Address already in use
ERROR: JDWP Transport dt_socket failed to initialize, TRANSPORT_INIT(510)
JDWP exit error AGENT_ERROR_TRANSPORT_INIT(197): No transports initialized [../../../src/share/back/debugInit.c:690]

Can anyone shed some light on this?

Regards,
Chetan
reply
    Bookmark Topic Watch Topic
  • New Topic