• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Liutauras Vilda
  • Jeanne Boyarsky
  • Devaka Cooray
  • Paul Clapham
Sheriffs:
  • Tim Cooke
  • Knute Snortum
  • Bear Bibeault
Saloon Keepers:
  • Ron McLeod
  • Tim Moores
  • Stephan van Hulst
  • Piet Souris
  • Ganesh Patekar
Bartenders:
  • Frits Walraven
  • Carey Brown
  • Tim Holloway

Web Sphere App Server 7.0 - 404 Not Found

 
Greenhorn
Posts: 6
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,
I configured my RAD with websphere 7.0. The server start up and my MDB (EJB 2.0) application gets published successfully (one War + One EAR) . But when i try to run the URL http://localhost:9082/ i get a 404 error. I thought if the server starts up at least the server console should be shown with that URL. Forget the war, the root itself throuws a 404. Can someone please help me.



Thanks and Regards
Vijay
 
Ranch Hand
Posts: 446
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
The websphere console is available at this URL:
https://<server>:<Administrative console secure port>/ibm/console/logon.jsp

Your successfully deployed web app will be available at this URL:
http://localhost:9082/<web context URI>

If you have not specified any context URI then its the name of the WAR file without extension (.war).
 
Vijay Kambhampati Sai
Greenhorn
Posts: 6
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thanks Deepak, but i just wanted to see if the server is started properly or not... so i gave the plain URL http://localhost:9082/ ...... doesn't that show some default page indicating the server started.... like tomcat would do.... that URL gives me a 404.... i am not trying to run my application....i just want to check the server start up......

i tried running my app with http://localhost:9082/xyz ....... but that threw me a 404.... so i tried checking the server with http://localhost:9082/ and that threw me a 404 as well....
 
Deepak Pant
Ranch Hand
Posts: 446
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
The Tomcat concept doesn't apply here in WAS. You can deploy couple of sample apps like SnoopServlet etc which you can access via browser URL.
 
Greenhorn
Posts: 4
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Im also facing the same error while running the localhost on websphere server."HTTP 404 NOT FOUND".
My rad is 7.0.0.1 and websphere is 6.1.23.server is also started
please tell what should be done
 
With a little knowledge, a cast iron skillet is non-stick and lasts a lifetime.
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!