• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Jeanne Boyarsky
  • Ron McLeod
  • Paul Clapham
  • Liutauras Vilda
Sheriffs:
  • paul wheaton
  • Rob Spoor
  • Devaka Cooray
Saloon Keepers:
  • Stephan van Hulst
  • Tim Holloway
  • Carey Brown
  • Frits Walraven
  • Tim Moores
Bartenders:
  • Mikalai Zaikin

link from JQuery is not working

 
Ranch Hand
Posts: 378
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I have one issue which I don't understand why it cannot work.

I have a page first load data from Servlet and display in a table(inside div1). Inside the table each row I have link attached to data.

When I click on the link, the dialog (div2) is not showing up.

But if i put static data on the table and have link attached to data, i click then it works, my div2 is shown on the screen.

So am I missing something in JQuery?

Let's see my code:


Part 2:


I checked the page, it loaded with my data but from browser's page source, it doesn't have data from JQuery script at all....it just display something like this


maybe that is why the link is not working? because of the rendered html code ?
i'm lost....


please help.
Regards
Nick
 
author
Posts: 15385
6
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator


You are appending table rows to a div, not a table.

Eric
 
Don't get me started about those stupid light bulbs.
reply
    Bookmark Topic Watch Topic
  • New Topic