• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Tim Cooke
  • Ron McLeod
  • Jeanne Boyarsky
  • Paul Clapham
Sheriffs:
  • Liutauras Vilda
  • Henry Wong
  • Devaka Cooray
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • Al Hobbs
  • Carey Brown
Bartenders:
  • Piet Souris
  • Mikalai Zaikin
  • Himai Minh

AdMob ad doesn't show in the emulator

 
Greenhorn
Posts: 12
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I wrote my first example app, and I try to import in it the Admob ads. I could make that in the Android 2.3.3 graphical layout, that the Ads by Google label is showing instead of com.google...AdView what is showing in every other graphical layout. From 1.6 to 2.2. I don't know why. I thought that my ads will showing only in Android 2.3.3, but wasn't.
Neither in 2.3.3 nor in 2.2 and below. My ad isn't showing in any emulator. But I don't know why, there aren't any error, except what in the 2.2 and lower layouts:

Parser is not a BridgeXmlBlockParser!

The following classes could not be instantiated:
- com.google.ads.AdView
See the Error Log (Window > Show View) for more details.

I don't know what I make bad.

Here is my layout file for this activity:




MY_PUBLISHER_CODE = my own publisher code

In the related java (android) class, I imported the



code.


In the manifest file, I imported this:



and the internet and network access permission.

Please help me, it's very annoying, that I don't know make this.
 
Don't get me started about those stupid light bulbs.
reply
    Bookmark Topic Watch Topic
  • New Topic