Win a copy of Five Lines of Code this week in the OO, Patterns, UML and Refactoring forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Bear Bibeault
  • Ron McLeod
  • Jeanne Boyarsky
  • Paul Clapham
Sheriffs:
  • Tim Cooke
  • Liutauras Vilda
  • Junilu Lacar
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • fred rosenberger
  • salvin francis
Bartenders:
  • Piet Souris
  • Frits Walraven
  • Carey Brown

Access denied message when I use - serverStatus command -- WAS V8

 
Greenhorn
Posts: 5
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
C:\Program Files (x86)\IBM\WebSphere\AppServer\bin>serverStatus -help
Access is denied.
!SESSION 2011-07-23 02:56:43.316 -----------------------------------------------

eclipse.buildId=M20060921-0945
java.fullversion=JRE 1.6.0 IBM J9 2.6 Windows 7 amd64-64 20110418_80450 (JIT ena
bled, AOT enabled)
J9VM - R26_Java626_GA_FP1_20110418_1915_B80450
JIT - r11_20110215_18645ifx8
GC - R26_Java626_GA_FP1_20110418_1915_B80450
J9CL - 20110418_80450
BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=en_US
Framework arguments: -application com.ibm.ws.bootstrap.WSLauncher
Command-line arguments: -application com.ibm.ws.bootstrap.WSLauncher

!ENTRY org.eclipse.osgi 4 0 2011-07-23 02:56:44.189
!MESSAGE Error reading configuration: C:\Program Files (x86)\IBM\WebSphere\AppSe
rver\profiles\AppSrv01\configuration\org.eclipse.osgi\.manager\.fileTableLock (A
ccess is denied.)
!STACK 0
java.io.FileNotFoundException: C:\Program Files (x86)\IBM\WebSphere\AppServer\pr
ofiles\AppSrv01\configuration\org.eclipse.osgi\.manager\.fileTableLock (Access i
s denied.)
at java.io.RandomAccessFile.open(Native Method)
at java.io.RandomAccessFile.<init>(RandomAccessFile.java:229)
at org.eclipse.core.runtime.internal.adaptor.Locker_JavaNio.lock(Locker_
JavaNio.java:33)
at org.eclipse.osgi.storagemanager.StorageManager.lock(StorageManager.ja
va:387)
at org.eclipse.osgi.storagemanager.StorageManager.open(StorageManager.ja
va:688)
at org.eclipse.osgi.internal.baseadaptor.BaseStorage.initFileManager(Bas
eStorage.java:213)
at org.eclipse.osgi.internal.baseadaptor.BaseStorage.initialize(BaseStor
age.java:147)
at org.eclipse.osgi.baseadaptor.BaseAdaptor.initializeStorage(BaseAdapto
r.java:114)
at org.eclipse.osgi.framework.internal.core.Framework.initialize(Framewo
rk.java:185)
at org.eclipse.osgi.framework.internal.core.Framework.<init>(Framework.j
ava:157)
at org.eclipse.core.runtime.adaptor.EclipseStarter.startup(EclipseStarte
r.java:286)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.ja
va:175)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.
java:60)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAcces
sorImpl.java:37)
at java.lang.reflect.Method.invoke(Method.java:611)
at org.eclipse.core.launcher.Main.invokeFramework(Main.java:340)
at org.eclipse.core.launcher.Main.basicRun(Main.java:282)
at org.eclipse.core.launcher.Main.run(Main.java:981)
at com.ibm.wsspi.bootstrap.WSPreLauncher.launchEclipse(WSPreLauncher.jav
a:371)
at com.ibm.wsspi.bootstrap.WSPreLauncher.main(WSPreLauncher.java:141)
 
Rancher
Posts: 3645
38
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Try to run command as an Administrator. Probably this is caused by user account protection in Windows 7.
 
San Ran
Greenhorn
Posts: 5
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I tired with the Admin account serverStatus -help -username XXXXXX -password XXXXXXX
it dint help
 
Mikalai Zaikin
Rancher
Posts: 3645
38
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
What was the error ? Same problem ?

Also, can you check if the file "C:\Program Files (x86)\IBM\WebSphere\AppSe
rver\profiles\AppSrv01\configuration\org.eclipse.osgi\.manager\.fileTableLock" exists ? If it exists, but not accessible, then you run no under Administrator.

Another guess - maybe you installed WAS not as an Administrator, and ut was installed into C:\Users\....Program Files....

Usually I try to avoid to install WebSphere in the "Program Files" folder.

I prefer to select some short name folder for WebSphere, without spaces in the name.

HTH,
MZ
 
San Ran
Greenhorn
Posts: 5
  • Likes 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thanks!!! The issue is resolved by running it a adminstrator.
 
Consider Paul's rocket mass heater.
    Bookmark Topic Watch Topic
  • New Topic