• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Ron McLeod
  • Paul Clapham
  • Bear Bibeault
  • Junilu Lacar
Sheriffs:
  • Jeanne Boyarsky
  • Tim Cooke
  • Henry Wong
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • salvin francis
  • Frits Walraven
Bartenders:
  • Scott Selikoff
  • Piet Souris
  • Carey Brown

New installation: Class loader exception:UnsatisfiedLinkError:isThreadAllocatedMemoryEnabled

 
Greenhorn
Posts: 2
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,

I hope somebody can understand this issue. Maybe something obvious, but I'm quite a newbie on this:

Each time I start Tomcat 6 (same result with 7), the progress bar barely goes up to the middle and in the log I get this type of error:
---
2011-10-19 16:04:50 Commons Daemon procrun stderr initialized
19 oct. 2011 16:04:50 org.apache.catalina.startup.Bootstrap initClassLoaders
GRAVE: Class loader creation threw exception
java.lang.UnsatisfiedLinkError: sun.management.VMManagementImpl.isThreadAllocatedMemoryEnabled()Z
at sun.management.VMManagementImpl.isThreadAllocatedMemoryEnabled(Native Method)
at sun.management.ThreadImpl.<init>(Unknown Source)
at sun.management.ManagementFactory.getThreadMXBean(Unknown Source)
at sun.management.ManagementFactory.createPlatformMBeanServer(Unknown Source)
at java.lang.management.ManagementFactory.getPlatformMBeanServer(Unknown Source)
at org.apache.catalina.startup.Bootstrap.createClassLoader(Bootstrap.java:183)
at org.apache.catalina.startup.Bootstrap.initClassLoaders(Bootstrap.java:92)
at org.apache.catalina.startup.Bootstrap.init(Bootstrap.java:207)
at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:391)
---

Additional information:
Windows 7 Home edition 64bit
EasyPHP 5.3.8.1
PHP 5.3.8 VC9
Apache 2.2.21 VC9
MySQL 5.5.16
Java 6

Thanks for any help.
Mac
 
Bartender
Posts: 4107
72
Hibernate Fedora Chrome
  • Likes 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Welcome to CodeRanch!

So you are running Tomcat through services? Have you try the zipped version of Tomcat whether it works?

And are you using compatible versions (64 bit/32 bit) of each JDK/Tomcat etc... here?
 
macalester thump
Greenhorn
Posts: 2
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thank you for giving me the good direction.

As I am on Windows 64 bit, I had the JDK in 64 bit. I found the good version and installed it.
Plus the Tomcat Installer set up itself on 64 bit automatically, so I used the zip version.
Finally, at the start up attempt I saw a wrong version of JRE being used, I had to do a set JRE_HOME=C:\Program Files (x86)\Java\jre6.

It was not that difficult, but I needed a tip. Thanks!
 
Vijitha Kumara
Bartender
Posts: 4107
72
Hibernate Fedora Chrome
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
You're welcome
 
And tomorrow is the circus! We can go to the circus! I love the circus! We can take this tiny ad:
Thread Boost feature
https://coderanch.com/t/674455/Thread-Boost-feature
    Bookmark Topic Watch Topic
  • New Topic