Win a copy of Testing JavaScript Applications this week in the HTML Pages with CSS and JavaScript forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
  • Campbell Ritchie
  • Bear Bibeault
  • Ron McLeod
  • Jeanne Boyarsky
  • Paul Clapham
  • Tim Cooke
  • Liutauras Vilda
  • Junilu Lacar
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • fred rosenberger
  • salvin francis
  • Piet Souris
  • Frits Walraven
  • Carey Brown

Process Portal CSS

Posts: 4
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

I am installing IBM BPM 7.5.
I have finished the installation after having a lot of problems (i bet the people who created the installation guide never did test it, because it just doesn’t work)

So, I start the Process Portal of one of my installed and running process servers, and to my surprise, the CSS is lacking and it just looks like shit.
Again, trying to resolve installation issues, i found a page that explains how to "customize" the CSS for the Portal, and the instructions start like this:

1 Make a back-up copy of the existing Portal.ear file. The Portal.ear file is in the <install-root>/BPM/Lombardi/process-server/applications directory.
2 If an unpacked Portal.ear directory is not present in <install-root>/BPM/Lombardi/tools/portal-app, unpack the Portal.ear file by running the redeployPortal utility (in the same portal-app directory) without parameters as follows: redeployPortal [.bat or .sh]

Ok, 1 was very easy to execute.
The 2, un the other hand, started with problems. I didnt have an unpacked Portal.ear, so i tried to execute the command as explained.

(path specified = <install-root>/BPM/Lombardi/process-server/)

Error number 1: was i checked, and it wasn’t in the specified path, so i copied i from the /bin of my process server profile, and continued
Error number 2: another *.sh wasn’t found. At this point, i just copied the directory bin from the process server profile to the path that it is looking for, so this type of error wont happen again, and continued
Error number 3: java not found in the path now i understand, that it needs the whole structure of the websphere bin and java in the path specified.. which for me is pathetic, because the guide says nothing about seems some one didn’t really test what they wrote.... so i copied the Java directory to where it was looking for...and continued...
Error number 4: ClassNotFounException:

Here is where i stopped. I do not know how to resolve this issue. Tried to google it, and nothing.
So now i guess im stuck with the default CSS of the process portal which is pretty ugly.

I have to say that IBM guides are just useless. Something that i estimated as 30 taking way more then that.
All the activities for the installation of the solution also present some problems, that i have overcome till now.
these guys really need to learn how to write guides that are tested by other users...because as this is a new product, the only help i have is the stupid guide

If anyone can help me with this issue, please!!!
Ofir Shani
Posts: 4
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
So, solving the issue, all that is needed is:

In the application web context root, modify the "/portal" to "/"
Restart the browser.
Modify the context root back to "/portal"
restart the browser.

And there you go.
If only this would of worked on the fly...
It's just a flesh wound! Or a tiny ad:
Thread Boost feature
    Bookmark Topic Watch Topic
  • New Topic