• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Liutauras Vilda
  • Jeanne Boyarsky
  • Devaka Cooray
  • Paul Clapham
Sheriffs:
  • Tim Cooke
  • Knute Snortum
  • Bear Bibeault
Saloon Keepers:
  • Ron McLeod
  • Tim Moores
  • Stephan van Hulst
  • Piet Souris
  • Ganesh Patekar
Bartenders:
  • Frits Walraven
  • Carey Brown
  • Tim Holloway

lookup failing with NPE in clustered environment

 
Greenhorn
Posts: 10
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hello,
In a clustered environment, NullPointer Exception is getting thrown whenever a specific ejb look up happens. This problem disappears after websphere restart. Following is the stack trace :

javax.naming.NamingException: Error during resolve [Root exception is java.lang.NullPointerException]
at com.ibm.ws.naming.jndicos.CNContextImpl.doLookup(CNContextImpl.java:1980)
at com.ibm.ws.naming.jndicos.CNContextImpl.doLookup(CNContextImpl.java:1883)
at com.ibm.ws.naming.jndicos.CNContextImpl.lookupExt(CNContextImpl.java:1566)
at com.ibm.ws.naming.jndicos.CNContextImpl.lookup(CNContextImpl.java:1363)
at com.ibm.ws.naming.util.WsnInitCtx.lookup(WsnInitCtx.java:172)
at javax.naming.InitialContext.lookup(InitialContext.java:363)
.....

The websphere version is 6.1 and ejb is 2.1. This problem is happening only when the system tries to invoke the bean for the first time after installation. Could any one please help to find out the problem?

In the ibm-ejb-jar-ext.xmi, a flag startEJBAtApplicationStart is used and set to true. Is that causing this NPE?


Thanks & Regards,
Zico
 
Consider Paul's rocket mass heater.
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!