• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Liutauras Vilda
  • Tim Cooke
  • Jeanne Boyarsky
  • Paul Clapham
Sheriffs:
  • Devaka Cooray
  • Ron McLeod
  • paul wheaton
Saloon Keepers:
  • Tim Moores
  • Piet Souris
  • Tim Holloway
  • Stephan van Hulst
  • Carey Brown
Bartenders:
  • Al Hobbs
  • Frits Walraven
  • Scott Selikoff

Publishing failing - Changing to Republish mode :( Please help !!

 
Greenhorn
Posts: 26
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I am trying to publish my ear and war modules into Oracle weblogic portal 10.3.0.0 server using workshop.
I am using pointbase DB.
But publishing failed since I was getting the following error,

weblogic.application.ModuleException: Exception preparing module: EJBModule(netuix.jar)Unable to deploy EJB: ProxyPagePersistenceManager from netuix.jar:
Exception while attempting to deploy Security Policy: weblogic.security.service.ResourceCreationException: weblogic.security.spi.ResourceCreationException: [Security:090310]Failed to create resource

So I tried to run create_db.cmd file present in the domain path and also deleted all ldap files and restarted the admin server. Now when I try to publish or clean publish, its exiting immediately (right after copying meta-inf to meta-inf displays) and going to Republish mode.

When I checked adminserver log, its having

####<Nov 11, 2011 1:48:46 PM IST> <Notice> <WebLogicServer> <AdminServer> <main> <<WLS Kernel>> <1320999526329> <BEA-000365> <Server state changed to RUNNING>
####<Nov 11, 2011 1:48:46 PM IST> <Notice> <WebLogicServer> <CINTNCHEOLY0GX7> <AdminServer> <main> <<WLS Kernel>> <1320999526376> <BEA-000360> <Server started in RUNNING mode>
####<Nov 11, 2011 1:48:53 PM IST> <Info> <EJB> <AdminServer> <[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <1320999533079> <BEA-010008> <EJB Deploying file: mejb.jar>
####<Nov 11, 2011 1:49:12 PM IST> <Info> <EJB> <AdminServer> <[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <1320999552939> <BEA-010009> <EJB Deployed EJB with JNDI name ejb.mgmt.MEJB.>
####<Nov 11, 2011 1:49:42 PM IST> <Info> <Health> <AdminServer> <weblogic.GCMonitor> <<anonymous>> <1320999582159> <BEA-310002> <84% of the total memory in the server is free>
####<Nov 11, 2011 1:56:26 PM IST> <Info> <JDBC> <AdminServer> <[ACTIVE] ExecuteThread: '1' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <1320999986185> <BEA-001128> <Connection for pool "portalDataSourceNeverXA" closed.>

I have pasted last few entries of the logs. Please help !

FYI, only after I executed create_db.cmd, this problem is occuring. Previously before running the cmd, there was atleast an attempt of deploying the modules but now there is no progress of deploying at all.
Shall I try to recreate the domain and try publishing again? Because I dont think there is any problem with my workspace. There are 6 projects (1 ear and 3 web projects) and no build errors. If you need more information please let me know.

 
Willie Smits increased rainfall 25% in three years by planting trees. Tiny ad:
the value of filler advertising in 2021
https://coderanch.com/t/730886/filler-advertising
reply
    Bookmark Topic Watch Topic
  • New Topic