• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Ron McLeod
  • Paul Clapham
  • Bear Bibeault
  • Junilu Lacar
Sheriffs:
  • Jeanne Boyarsky
  • Tim Cooke
  • Henry Wong
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • salvin francis
  • Frits Walraven
Bartenders:
  • Scott Selikoff
  • Piet Souris
  • Carey Brown

STRUTS html:param taglib

 
Ranch Hand
Posts: 148
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,

I'm using the MyEclipse dev studio for my web application and I'm running into issues. I'm trying to use the struts <html aram> taglib, but the application does not seem to recognize it. I checked in struts-html.tld and it's not in there.

So, I'm wondering what settings I need to change in order to use this feature. I'm using MyEclipse 5.1.

Here's my a sample of my code:

<td>
<html:link forward="saveFavorite">*SAVE AS FAVORITE<html aram name="businessID" value="1" />
</html:link></td>
<td><html:link forward="feedback" paramId="businessName" >
*PROVIDE FEEDBACK</html:link></td>

Please HeLP!!!
 
Ranch Hand
Posts: 4864
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I suspect the problem may be the version of the taglib that you're using. <html:param> is only available in Struts Version 1.3.8, which is the latest Struts 1 release. If you're using any earlier versions, the tag won't be recognized.
[ April 25, 2007: Message edited by: Merrill Higginson ]
    Bookmark Topic Watch Topic
  • New Topic