• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Bear Bibeault
  • Ron McLeod
  • Jeanne Boyarsky
  • Paul Clapham
Sheriffs:
  • Tim Cooke
  • Liutauras Vilda
  • Junilu Lacar
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • fred rosenberger
  • salvin francis
Bartenders:
  • Piet Souris
  • Frits Walraven
  • Carey Brown

JasperException

 
Ranch Hand
Posts: 186
Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Dear friends,

I have this problem spoiling my development.
I have written the following JSP in NetBeans 5.5.1


Following is the Form class:


Following is the Action class:





The following are the entries in struts-config.xml:



When i deploy the JSP, i am getting this error:
org.apache.jasper.JasperException: Unable to find setter method for attribute: name


So friends, kindly provide your patience to go through this problem and help me get out of the pit.

Thanks in advance,
Vijay
[ July 17, 2007: Message edited by: vijaychandran rajagopalan ]
 
Sheriff
Posts: 13411
Firefox Browser VI Editor Redhat
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Other than in your struts form tag, I don't see anyplace in your JSP where you would be trying to set a name property.
I would start by going through stack traces in the logs to see if there is a line number in either the JSP or the generated servlet code where you can go for more hints.

Since this is a Struts project and since you aren't getting any help here, I'm going to move this to our Struts forum.
[ July 17, 2007: Message edited by: Ben Souther ]
 
Ranch Hand
Posts: 4864
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I believe NetBeans uses Struts 1.2.9. In this version of struts, the name and type attributes of the <html:form> tag are deprecated. Just remove them, and your page should work fine. They aren't really necessary anyway as you've already defined this information in your struts-config.xml file.
 
Don't get me started about those stupid light bulbs.
    Bookmark Topic Watch Topic
  • New Topic