Win a copy of Micro Frontends in Action this week in the Server-Side JavaScript and NodeJS forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Liutauras Vilda
  • Paul Clapham
  • Bear Bibeault
  • Jeanne Boyarsky
Sheriffs:
  • Ron McLeod
  • Tim Cooke
  • Devaka Cooray
Saloon Keepers:
  • Tim Moores
  • Tim Holloway
  • Jj Roberts
  • Stephan van Hulst
  • Carey Brown
Bartenders:
  • salvin francis
  • Scott Selikoff
  • fred rosenberger

NullPointerException running Spring in main() from DefaultListableBeanFactory

 
Ranch Hand
Posts: 68
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
So I have a spring webapp. Works fine. But our test classes, when run as main() apps are blowing up with the following exceptions:



NPE coming from here:


I've seen some posts online suggesting that this means the class loader is null. One recommended citing jars explicitly rather than using a directory. Another suggested that it was the load order of required jars. I don't see how either of these is my issue. I am running from Run As.. in Eclipse and have included all jars directly under the 'bootstrap' part of the classpath tab, just to make sure the jars were as early as possible.

Anyone know this issue?
 
Everybody's invited. Even this tiny ad:
Thread Boost feature
https://coderanch.com/t/674455/Thread-Boost-feature
reply
    Bookmark Topic Watch Topic
  • New Topic