• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Liutauras Vilda
  • Junilu Lacar
  • Jeanne Boyarsky
  • Bear Bibeault
Sheriffs:
  • Knute Snortum
  • Devaka Cooray
  • Tim Cooke
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • Ron McLeod
  • Carey Brown
Bartenders:
  • Paweł Baczyński
  • Piet Souris
  • Vijitha Kumara

java.lang.IllegalArgumentException: class has neither @WebSerivce nor @WebServiceProvider annotation

 
Ranch Hand
Posts: 69
Netbeans IDE Firefox Browser Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi I have just started on webservices and while running a simple program from Java webservices up and running(O Reilly) book i encountered (java.lang.IllegalArgumentException: class ch01.ts.TimeServerPublisher has neither @WebSerivce nor @WebServiceProvider annotation.Here is teh code that I have written so far:


Any suggestions would be helpful.
Thanks

 
Bartender
Posts: 4106
72
Hibernate Fedora Chrome
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
How you compile/generate the artifacts? And how you run the code, your environment etc...?

People may not have the book you are referring to with them so some background may needed here...
 
Ranch Hand
Posts: 208
9
Eclipse IDE Firefox Browser Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Are you sure you want this:

and not this:
 
udaya krishna
Ranch Hand
Posts: 69
Netbeans IDE Firefox Browser Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi thanks for the response..I am using eclipse IDE and jdk 6.0(jdk1.6.0_22) for compiling and running the code on windows XP..And Tina, I changed

to

thats a silly one ..Its working now . I am able to access the wsdl..and am i the only one who noticed @WebService misspelled as @WebSerivce :0
Thanks for the help
 
Everybody! Do the Funky Monkey! Like this tiny ad!
Java file APIs (DOC, XLS, PDF, and many more)
https://products.aspose.com/total/java
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!