This week's book giveaway is in the Cloud forum.
We're giving away four copies of Terraform in Action and have Scott Winkler on-line!
See this thread for details.
Win a copy of Terraform in Action this week in the Cloud forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Tim Cooke
  • Campbell Ritchie
  • Paul Clapham
  • Ron McLeod
  • Liutauras Vilda
Sheriffs:
  • Jeanne Boyarsky
  • Rob Spoor
  • Bear Bibeault
Saloon Keepers:
  • Jesse Silverman
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • Carey Brown
Bartenders:
  • Piet Souris
  • Al Hobbs
  • salvin francis

In eclipse, JavaScript file changes reflect after 3-4 times refreshing the project

 
Ranch Hand
Posts: 80
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Initially when i was load web project into eclipse, that time my every change reflect quickly.
As development going on, my project code become too large and new 20-25 jars are added to project. Now I change any javascript file and check the change in browser, that will reflect only after 3-4 times refreshing the project.

Is it the problem of too many files in the project or too many projects in eclipse or both?

Please help me, I got frustrated many times if javascript change is not reflecting.

 
Ranch Hand
Posts: 56
Netbeans IDE Eclipse IDE Tomcat Server
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
think this may work, i had a similar problem, in Eclipse

try any one of the below set of steps.

1.every time you make changes,
2.build and clean your project,
3.and you can right-click on your server and the click clean. (the IDE will remove all the old files and then deploy your new deployment. )


you can also use this method,
1. After making your changes you can clean your project.
2.right click on the server in servers window, then click on Explore, this will open folder where the deployments are present, then you can delete the deployment manually.( ie this folder will have the war or the Exploded form of war, you can select the war and delete the war by simply right click and delete)
3. now right click on your project and run on server.



the reason behind this problem might be due to the fact that, the deployment is done once and the next time the IDE does not properly update the deployment,

there is also on more possiblity, that your project might be large, that might also affect the refreshing time, or your system might be running so many othere process so try to remove the unwanted process from your task Manager,

(ie open your task Manager and then select process tab and then select the process that are not useful for you, thus the system performance will increase).

these are possible answers that i can give you, so try them.
 
Bartender
Posts: 1111
Eclipse IDE Oracle VI Editor
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I used to find just putting a small version number in my html page, that i changed when i changed the javascript seemed to do the job, it forced something to recompile, and you could easily see if it hadn't recompiled.
 
Ranch Hand
Posts: 859
IBM DB2 Chrome Java
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
javascript is not compiled by the application server.

It is simply hosted and sent back to the browser to be executed within the HTML.

In some cases, the browser will cache the js (as it does with .gif,.jpg,.css) etc..

Hold down the Shift (or Ctrl) and hit Refresh/F5 and you should force the browser to retrieve the latest versions.

Using firebug or IE dev tools, there are options to never cache static web content.


WP
 
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Although it has been 9 years since this is posted

however it is valid until now. I had the same problem for a good while now  , then came across this solution

thank you

Bazama
 
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Thank you so much!!! I had the same issue and I solved it Refreshing the browser worked for me
 
You showed up just in time for the waffles! And this tiny ad:
Building a Better World in your Backyard by Paul Wheaton and Shawn Klassen-Koop
https://coderanch.com/wiki/718759/books/Building-World-Backyard-Paul-Wheaton
reply
    Bookmark Topic Watch Topic
  • New Topic