Win a copy of Practice Tests for OCP Java 17 Certification Exam (1Z0-829) this week in the OCPJP forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Tim Cooke
  • Campbell Ritchie
  • Jeanne Boyarsky
  • Ron McLeod
  • Liutauras Vilda
Sheriffs:
  • Rob Spoor
  • Junilu Lacar
  • paul wheaton
Saloon Keepers:
  • Stephan van Hulst
  • Tim Moores
  • Tim Holloway
  • Carey Brown
  • Scott Selikoff
Bartenders:
  • Piet Souris
  • Jj Roberts
  • fred rosenberger

AWT Component Loading Issue After Accessing it for a while

 
Ranch Hand
Posts: 42
Android Eclipse IDE Spring
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi,

I've a AWT Java application which is accessible by a JSP page. JSP pages are deployed in a web application and AWT classes are inside a Java application. Both web and Java is bundled in an ear file which is installed on an IBM websphere application server 7.

AWT application is launched by a JSP login page. There are different buttons in that AWT app to access different functionalities of the application. They all makes database call (simple CRUD operation) to save/update database record.

When multiple user (5 user) log in to the system with their credentials, after sometime, AWT application stops responding. Application starts hanging/freezing after sometime. When you click on one functionality, the child frame does not paint correctly and due to this, input form fields of child frame does not load. You have to close the AWT main window and then re-login to access the AWT application.


We're not able to replicate this with single user. We've then tested it with 4 user and there was no issue. When we've increased user to 5 i.e., 5 users concurrently accessing AWT application, then we have got this screen freezing problem (child frame components not loading correctly after sometime of access).

Does anyone have faced this issue in AWT?

Any idea how to approach and find the root cause for this.

Thanks,
Nazz
 
Ranch Hand
Posts: 177
Hibernate Python Linux
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
This sounds more like a concurrency problem in your database code than anything else.
I got little knowledge about jsp, so what i am saying might be totally wrong but it sounds like you run all your database code in the event dispatch thread so the gui is freezing when long running tasks or concurrent situation occur.
 
reply
    Bookmark Topic Watch Topic
  • New Topic