• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Ron McLeod
  • Tim Cooke
  • Liutauras Vilda
  • Jeanne Boyarsky
Sheriffs:
  • Paul Clapham
  • Rob Spoor
  • Junilu Lacar
Saloon Keepers:
  • Stephan van Hulst
  • Tim Holloway
  • Piet Souris
  • Carey Brown
Bartenders:

cannot connect to the internet through yamba app

 
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hello everyone,

I am facing a peculiar issue when connecting to the internet through the emulator. I am using r19 development tools and emulator as 2.2. I am working on the yamba app from learning android book. This app connects to the internet for the website yamba.marakana.com. The problem is , through the emulator i am able to to connect to the internet and visit websites such as google and the site mentioned above. However through my application, it gives me a UnknownHostException saying host is unresolved at yamba.marakana.com/api:80.

I have added the permissions for Internet in manifest as well. Attached is the manifest file. Let me know if anything additional is required to be done.




Thanks in advance

ps : brought to my notice about cross posting. Hence, I have already asked this on stack overflow and my awaiting a reply.
ps : any other etiquette i should know about ?
 
clojure forum advocate
Posts: 3479
Mac Objective C Clojure
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hello Sadanand and welcome to the Ranch!
Would you please BeForthrightWhenCrossPostingToOtherSites ?
Thank you.
 
Ranch Hand
Posts: 35
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
For the benefit of other learners, this error is most likely caused by a bug in the emulator software. Restart the emulator and try to connect to the api again.

Look towards the top of the emulator screen and check that the emulator has network connectivity.



If the emulator does not have connectivity, UnknownHostException appears to be thrown.
reply
    Bookmark Topic Watch Topic
  • New Topic