• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Ron McLeod
  • Paul Clapham
  • Bear Bibeault
  • Junilu Lacar
Sheriffs:
  • Jeanne Boyarsky
  • Tim Cooke
  • Henry Wong
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • salvin francis
  • Frits Walraven
Bartenders:
  • Scott Selikoff
  • Piet Souris
  • Carey Brown

Manual install Beta 2.1.7

 
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi!
I have installed 2.16 but I got a lot of bugs. Then I tries to upgrade to 2.17 but dont find any upgrade-file.

Ok...I start all over...tries to install 2.17 from scratch. This time I cant find new_rename.htm in the root directoy? So I tried and took the index.htm from 2.16....didnt work.

This is how it looks now, I guess something is wrong with its "start-file". http://83.227.20.57:8080/jforum/

System: JEE5

Regards
[originally posted on jforum.net by Zedrick76]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
The documentation is available in the "Support" link in the top menu, or in the "Documentation" link in the left menu.

The doc you're searching for is at http://www.jforum.net/doc/UpgradingFrom2.1.6To2.1.7

Rafael
[originally posted on jforum.net by Rafael Steil]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thx Rafael,
but I have already read the doc. Still, I cant find the upgrade script as I already have told.
[originally posted on jforum.net by Zedrick76]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
What if you try /jforum/forums/list.page?

See in the logs for errors.
[originally posted on jforum.net by lazee]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Do did not get any message at all. I re-deployed jforum and got this:

Logger: javax.enterprise.system.container.web
Name-Value Pairs: _ThreadID=17;_ThreadName=Thread-28;_RequestID=6aceefaa-e15b-450f-a21d-59da4d00169b;
Record Number: 404
Message ID: WebModule[/jforum]Error configuring application listener of class net.jforum.ForumSessionListener java.lang.ClassNotFoundException

Complete Message
net.jforum.ForumSessionListener at org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1511) at org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1292) at org.apache.catalina.core.StandardContext.listenerStart(StandardContext.java:4181) at org.apache.catalina.core.StandardContext.start(StandardContext.java:4760) at com.sun.enterprise.web.WebModule.start(WebModule.java:292) at org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:833) at org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:817) at org.apache.catalina.core.StandardHost.addChild(StandardHost.java:662) at com.sun.enterprise.web.WebContainer.loadWebModule(WebContainer.java:1479) at com.sun.enterprise.web.WebContainer.loadWebModule(WebContainer.java:1143) at com.sun.enterprise.server.WebModuleDeployEventListener.moduleDeployed(WebModuleDeployEventListener.java:171) at com.sun.enterprise.server.WebModuleDeployEventListener.moduleDeployed(WebModuleDeployEventListener.java:275) at com.sun.enterprise.admin.event.AdminEventMulticaster.invokeModuleDeployEventListener(AdminEventMulticaster.java:954) at com.sun.enterprise.admin.event.AdminEventMulticaster.handleModuleDeployEvent(AdminEventMulticaster.java:941) at com.sun.enterprise.admin.event.AdminEventMulticaster.processEvent(AdminEventMulticaster.java:448) at com.sun.enterprise.admin.event.AdminEventMulticaster.multicastEvent(AdminEventMulticaster.java:160) at com.sun.enterprise.admin.server.core.DeploymentNotificationHelper.multicastEvent(DeploymentNotificationHelper.java:296) at com.sun.enterprise.deployment.phasing.DeploymentServiceUtils.multicastEvent(DeploymentServiceUtils.java:203) at com.sun.enterprise.deployment.phasing.ServerDeploymentTarget.sendStartEvent(ServerDeploymentTarget.java:285) at com.sun.enterprise.deployment.phasing.ApplicationStartPhase.runPhase(ApplicationStartPhase.java:119) at com.sun.enterprise.deployment.phasing.DeploymentPhase.executePhase(DeploymentPhase.java:95) at com.sun.enterprise.deployment.phasing.PEDeploymentService.executePhases(PEDeploymentService.java:871) at com.sun.enterprise.deployment.phasing.PEDeploymentService.start(PEDeploymentService.java:541) at com.sun.enterprise.deployment.phasing.PEDeploymentService.start(PEDeploymentService.java:585) at com.sun.enterprise.admin.mbeans.ApplicationsConfigMBean.start(ApplicationsConfigMBean.java:719) at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25) at java.lang.reflect.Method.invoke(Method.java:585) at com.sun.enterprise.admin.MBeanHelper.invokeOperationInBean(MBeanHelper.java:353) at com.sun.enterprise.admin.MBeanHelper.invokeOperationInBean(MBeanHelper.java:336) at com.sun.enterprise.admin.config.BaseConfigMBean.invoke(BaseConfigMBean.java:448) at com.sun.jmx.mbeanserver.DynamicMetaDataImpl.invoke(DynamicMetaDataImpl.java:213) at com.sun.jmx.mbeanserver.MetaDataImpl.invoke(MetaDataImpl.java:220) at com.sun.jmx.interceptor.DefaultMBeanServerInterceptor.invoke(DefaultMBeanServerInterceptor.java:815) at com.sun.jmx.mbeanserver.JmxMBeanServer.invoke(JmxMBeanServer.java:784) at sun.reflect.GeneratedMethodAccessor24.invoke(Unknown Source) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25) at java.lang.reflect.Method.invoke(Method.java:585) at com.sun.enterprise.admin.util.proxy.ProxyClass.invoke(ProxyClass.java:77) at $Proxy1.invoke(Unknown Source) at com.sun.enterprise.admin.server.core.jmx.SunoneInterceptor.invoke(SunoneInterceptor.java:297) at com.sun.enterprise.deployment.client.DeploymentClientUtils.startApplication(DeploymentClientUtils.java:133) at com.sun.enterprise.deployment.client.DeployAction.run(DeployAction.java:517) at java.lang.Thread.run(Thread.java:595)


[originally posted on jforum.net by Zedrick76]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Sry but I still cant find any upgrade-file nor new_rename.htm in the root directoy.

Can plz someone send me those??

Zedrick76
[originally posted on jforum.net by Zedrick76]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

Zedrick76 wrote:Message ID: WebModule[/jforum]Error configuring application listener of class net.jforum.ForumSessionListener java.lang.ClassNotFoundException



Are you using the 2.1.7 CVS version? When I get that I launch Eclipse and clean/recompile.


[originally posted on jforum.net by MyJForum]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Im not sure what CVS version is but I use the "compiled" version...I will try clean/recompile. Thx
[originally posted on jforum.net by Zedrick76]
 
Don't get me started about those stupid light bulbs.
    Bookmark Topic Watch Topic
  • New Topic