This week's book giveaway is in the Java in General forum.
We're giving away four copies of Event Streams in Action and have Alexander Dean & Valentin Crettaz on-line!
See this thread for details.
Win a copy of Event Streams in Action this week in the Java in General forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Devaka Cooray
  • Liutauras Vilda
  • Jeanne Boyarsky
  • Bear Bibeault
Sheriffs:
  • Paul Clapham
  • Knute Snortum
  • Rob Spoor
Saloon Keepers:
  • Tim Moores
  • Ron McLeod
  • Piet Souris
  • Stephan van Hulst
  • Carey Brown
Bartenders:
  • Tim Holloway
  • Frits Walraven
  • Ganesh Patekar

Using gmail as my SMTP server

 
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hey
I'm having a bit of trouble using Gmail as my SMTP server. I'm using jforum 2.1.8 and in the admin console I have the following settings:

Email Address to use as "sender" me@gmail.com
SMTP Server smtp.gmail.com
SMTP Port [See below]
SMTP Server requires authorization? True
Requires SSL? False
SMTP username ( only if using authorization ) me@gmail.com
SMTP password ( only if using authorization ) mypassword
Send a test email E-mail: me@yahoo.com

If I set the port to be 25 I get this error:

MUST ISSUE A STARTTLS command first

So then I tried port 465 and it just hangs....

Any ideas?
Thanks in advance

[originally posted on jforum.net by sroberts82]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
try port 587
[originally posted on jforum.net by bwfrieds]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
hi,
I get the same error on port 587: MUST ISSUE STARTTLS
[originally posted on jforum.net by sroberts82]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
So that just means that the ssl connection is not established, right?

http://mail.google.com/support/bin/answer.py?hl=en&answer=13287&disablechatbrowsercheck=1
[originally posted on jforum.net by bwfrieds]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
great stuff, thanks. For anyone else my settings are:

Email Address to use as "sender" me@gmail.com
SMTP Server smtp.gmail.com
SMTP Port 465
SMTP Server requires authorization? True
Requires SSL? True
SMTP username ( only if using authorization ) me@gmail.com
SMTP password ( only if using authorization ) mypassword
Send a test email E-mail: me@yahoo.com
[originally posted on jforum.net by sroberts82]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thanks sroberts82!

I had the same problem but now it works like a charm using these settings!
[originally posted on jforum.net by jmrsjcds]
 
It is sorta covered in the JavaRanch Style Guide.
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!