Win a copy of Testing JavaScript Applications this week in the HTML Pages with CSS and JavaScript forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Bear Bibeault
  • Ron McLeod
  • Jeanne Boyarsky
  • Paul Clapham
Sheriffs:
  • Tim Cooke
  • Liutauras Vilda
  • Junilu Lacar
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • fred rosenberger
  • salvin francis
Bartenders:
  • Piet Souris
  • Frits Walraven
  • Carey Brown

struts2 and displaytag confiuration problem

 
Ranch Hand
Posts: 755
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
rhhhrhrrrr

I've been trying unsuccessfully to get around this for the past 2 days and still nothing!

simply, I'm trying to incorporate strtsu2 with displayTag (works great with my struts1 application)

1. web.xml:


2 jars reference: (A) displaytag-1.1.1.jar (B) displayTag-export-poi-1.1.1.jar

3. WebContent/WEB-INF/displaytag-11.tld

4. action: (size of list is 5)


5. jsp:



result: NOTHING!!!

not even a message: nothing found to display.

any idea?!?!?
 
Ranch Hand
Posts: 53
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
You are trying to do using Struts2.x or Struts1.x.In Struts2.x, no more tlds ,Just you need to add required jar files in your class path.

In your jsp, just add this line on top

get your values as List from your Action,then design your table in Jsp like below.


And add displaytag-1.1.jar file in your applications's WEB-INF/lib
Try...
 
Greenhorn
Posts: 10
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
what exactly the value of excludeParams attribute do we need to give?
Does this solvs the problem. I tried all the things except the exclude params.

In the original problem if i remove the attribute "name" then it atleast shows the "Nothing to display" message.
however if the "name " attribute is present the it gives an error on the console "......No class definition found: ... NestedNullException"
Couldn't find the reason for this.

Please help
 
Beware the other head of science - it bites! Nibble on this message:
Building a Better World in your Backyard by Paul Wheaton and Shawn Klassen-Koop
https://coderanch.com/wiki/718759/books/Building-World-Backyard-Paul-Wheaton
    Bookmark Topic Watch Topic
  • New Topic