• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Liutauras Vilda
  • Junilu Lacar
  • Jeanne Boyarsky
  • Bear Bibeault
Sheriffs:
  • Knute Snortum
  • Tim Cooke
  • Devaka Cooray
Saloon Keepers:
  • Ron McLeod
  • Stephan van Hulst
  • Tim Moores
  • Tim Holloway
  • Carey Brown
Bartenders:
  • Piet Souris
  • Frits Walraven
  • Ganesh Patekar

JForum Manual Database Setup

 
Greenhorn
Posts: 13
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,
I had installed JForum successfully,my requirement is ,when ever i deploy war file of JForum into the server....it is asking install page (for every time war is deployed in server)..if we go for install database is recreated and all the data is getting lose..

How to skip this install.jsp
reply me please
 
author & internet detective
Posts: 39525
772
Eclipse IDE VI Editor Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Are you going to the install page or is it redirecting you there?

One thing we did here was to take the precaution here of deleting the jsp so it's not in the war to be run.
 
sasikanth ravipudi
Greenhorn
Posts: 13
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thanks for replying Jeanne,its redirecting me to the install.jsp page
 
Jeanne Boyarsky
author & internet detective
Posts: 39525
772
Eclipse IDE VI Editor Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
There's a property file that stores settings once you've installed. (jforum-custom.conf). Is it possible this file is getting overridden when you deploy?
 
sasikanth ravipudi
Greenhorn
Posts: 13
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi Jeanne,
Actually thats not created in my project ,because i tried to get forums/list.page instead of installl.jsp ,some modification i have done in source code,because of not having install action that (jform-custom.conf) is not created.
I manually copied that file from another jforum project and...thats worked ,but the problem is if i copied that file into project(that is in eclipse) and build war file of my project,thats not working,when i manually copied only its working..

thanks Jeanne
 
It's a pleasure to see superheros taking such an interest in science. And this tiny ad:
Java file APIs (DOC, XLS, PDF, and many more)
https://products.aspose.com/total/java
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!