Win a copy of Murach's MySQL this week in the JDBC and Relational Databases forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Jeanne Boyarsky
  • Ron McLeod
  • Paul Clapham
  • Liutauras Vilda
Sheriffs:
  • paul wheaton
  • Rob Spoor
  • Devaka Cooray
Saloon Keepers:
  • Stephan van Hulst
  • Tim Holloway
  • Carey Brown
  • Frits Walraven
  • Tim Moores
Bartenders:
  • Mikalai Zaikin

Not able to config xuggler from git source for LD_LIBRARY_PATH for Xuggler.

 
Ranch Hand
Posts: 48
1
Tomcat Server Java Ubuntu
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I tried installing and setting up xuggler in ubutnu 12.04 LTS but I am not able to set up the LD_LIBRARY_PATH.

I performed all the steps provided on xuggler build website: http://www.xuggle.com/xuggler/build but all in vain.

I had setup the paths needed in /etc/environment section as follows -


and restarted the system.

I am facing problem in these areas -

In Setting up your Environment section, it has been told to set up a path known as: LD_LIBRARY_PATH=$XUGGLE_HOME/lib:$LD_LIBRARY_PATH. When I did the following: echo $XUGGLE_HOME, I am getting output as /usr/local/xuggle, but when I say echo $LD_LIBRARY_PATH, I get a blank line.

/usr/local/xuggle/lib folder actually does not exists even after successful built. Then why set the LD_LIBRARY_PATH as $XUGGLE_HOME/lib:... ?? Instead I found lib in /usr/local/xuggle/dist/stage/i686-pc-linux-gnu/usr/local/lib.

I also found on at some places that ubuntu does not takes LD_LIBRARY_PATH in /etc/environment, instead it takes it from /etc/ld.so.conf.d/. So I tried setting the above path here and then do sudo ldconfig, but again no success.

I also followed this link: http://linux.101hacks.com/unix/ldconfig/, but still not successful.

Where am I making a mistake? When I try using xuggler in my Java EE Project, I get following error:


Can anyone help me? I can provide more accurate information if needed. Thanks in advance.
 
Consider Paul's rocket mass heater.
reply
    Bookmark Topic Watch Topic
  • New Topic