• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Paul Clapham
  • Tim Cooke
  • Jeanne Boyarsky
  • Liutauras Vilda
Sheriffs:
  • Frank Carver
  • Henry Wong
  • Ron McLeod
Saloon Keepers:
  • Tim Moores
  • Frits Walraven
  • Tim Holloway
  • Stephan van Hulst
  • Carey Brown
Bartenders:
  • Al Hobbs
  • Piet Souris
  • Himai Minh

Tomcat seems to be started via console. But unable to access through browser

 
Greenhorn
Posts: 23
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hello Everyone,

I copied tomcat5.5 and executed startup.bat. It is started and I got the message as seen below


Startup Log


Jul 4, 2012 6:15:24 PM org.apache.catalina.core.AprLifecycleListener init
INFO: Loaded APR based Apache Tomcat Native library 1.1.20.
Jul 4, 2012 6:15:24 PM org.apache.catalina.core.AprLifecycleListener init
INFO: APR capabilities: IPv6 [true], sendfile [true], accept filters [false],
ndom [true].
Jul 4, 2012 6:15:24 PM org.apache.coyote.http11.Http11AprProtocol init
INFO: Initializing Coyote HTTP/1.1 on http-8080
Jul 4, 2012 6:15:24 PM org.apache.coyote.http11.Http11AprProtocol init
INFO: Initializing Coyote HTTP/1.1 on http-443
Jul 4, 2012 6:15:24 PM org.apache.coyote.ajp.AjpAprProtocol init
INFO: Initializing Coyote AJP/1.3 on ajp-8009
Jul 4, 2012 6:15:24 PM org.apache.catalina.startup.Catalina load
INFO: Initialization processed in 406 ms
Jul 4, 2012 6:15:24 PM org.apache.catalina.core.StandardService start
INFO: Starting service Catalina
Jul 4, 2012 6:15:24 PM org.apache.catalina.core.StandardEngine start
INFO: Starting Servlet Engine: Apache Tomcat/5.5.30
Jul 4, 2012 6:15:24 PM org.apache.catalina.core.StandardHost start
INFO: XML validation disabled
Jul 4, 2012 6:15:25 PM org.apache.coyote.http11.Http11AprProtocol start
INFO: Starting Coyote HTTP/1.1 on http-8080
Jul 4, 2012 6:15:25 PM org.apache.coyote.http11.Http11AprProtocol start
INFO: Starting Coyote HTTP/1.1 on http-443
Jul 4, 2012 6:15:25 PM org.apache.coyote.ajp.AjpAprProtocol start
INFO: Starting Coyote AJP/1.3 on ajp-8009
Jul 4, 2012 6:15:25 PM org.apache.catalina.storeconfig.StoreLoader load
INFO: Find registry server-registry.xml at classpath resource
Jul 4, 2012 6:15:25 PM org.apache.catalina.startup.Catalina start
INFO: Server startup in 546 ms


As per the log I assumed that the server gets started up and tried to access through the URL http://localhost:8080 and its showing server not found/page cannot be displayed message.

Could anyone let me advice on the possibilities for this issue.

Any valuable input is highly appreciated.


Thanks in advance
NikhilChandran.


 
Saloon Keeper
Posts: 26011
186
Android Eclipse IDE Tomcat Server Redhat Java Linux
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Tomcat can start up fast, but not that fast!

It appears that you haven't deployed any web applications to the Tomcat server.

What would pretty much seal the case is if the error pages you're getting are Tomcat's "404" Resource Not Found status pages, because in that case, you are accessing Tomcat, but Tomcat has no content to deliver.
 
Ranch Hand
Posts: 36
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
It might be on wrong port.
check your server.xml for the port
 
God is a comedian playing for an audience that is afraid to laugh - Voltair. tiny ad:
the value of filler advertising in 2021
https://coderanch.com/t/730886/filler-advertising
reply
    Bookmark Topic Watch Topic
  • New Topic