Win a copy of Svelte and Sapper in Action this week in the JavaScript forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Ron McLeod
  • Paul Clapham
  • Bear Bibeault
  • Junilu Lacar
Sheriffs:
  • Jeanne Boyarsky
  • Tim Cooke
  • Henry Wong
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • salvin francis
  • Frits Walraven
Bartenders:
  • Scott Selikoff
  • Piet Souris
  • Carey Brown

Seam app stuck in redirect loop

 
Greenhorn
Posts: 2
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi all,

I'm sorry if this is not the right forum for this but my seam app is running in tomcat right now and I'm unsure where the error is happening.

I'm struggling with an odd issue that I can't seem to find a solution too. When I go to access my seam application I'm running into this "This webpage has a redirect loop" in both Chrome and Firefox. I've got one warning "WARN org.jboss.seam.security.permission.PersistentPermissionResolver- no permission store available - please install a PermissionStore with the name 'org.jboss.seam.security.jpaPermissionStore' if persistent permissions are required." but no errors in my tomcat logs for starting the server or when I try hitting my webapp. When I go to http:localhost:8080/myapp it tries to go to home.seam but it then says that it has been temporarily moved and then goes through the redirect loop as it tries to go to debug.seam over and over.

I'm using Seam 2.2.2.Final and Tomcat 6.0.35. I generated my project and entities with seam-gen.

I've attached my components.xml, persistence-dev.xml and components.xml but I'll put the text into this post as well.

I've been struggling with this for over a week now and just don't have any ideas left.

I think that is all the information needed but if I've missed something let me know.







Thanks

Chris
 
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I have the same problem?

You have already solved?

How?

Thanks.
 
No matter. Try again. Fail again. Fail better. This time, do it with this tiny ad:
Thread Boost feature
https://coderanch.com/t/674455/Thread-Boost-feature
    Bookmark Topic Watch Topic
  • New Topic