Win a copy of Spring Boot in Practice this week in the Spring forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Tim Cooke
  • Ron McLeod
  • Jeanne Boyarsky
  • Paul Clapham
Sheriffs:
  • Liutauras Vilda
  • Henry Wong
  • Devaka Cooray
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • Al Hobbs
  • Carey Brown
Bartenders:
  • Piet Souris
  • Mikalai Zaikin
  • Himai Minh

Problem: JSF with PrimeFaces

 
Ranch Hand
Posts: 88
IBM DB2 Eclipse IDE Java
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi everyone, please help me to find my mistake. I was trying to run simple "Hello World" PrimeFaces example as explained in their doc but couldn't run successfully.

In PrimeFaces Doc 3.3 it says I should be able to run the following code after confirming two dependencies such as "Java 5+ runtime" and "JSF 2.x"

Now, my config is as follows:
Eclipse: INDIGO
Server: Websphere 7
Project Facets: JavaServer Faces 2.0
Java Build Path:
-JSF 2.0 (Apache Myfaces JSF Core-2.0 API 2.0.2)
-JSTL : jstl-api-1.2.jar, jstl-impl-1.2.jar
-Primefaces: primefaces-3.3.1.jar
Simple web.xml is as follows:

faces-config.xml is as follows:

And finally "index.jsp" page is as follows:
When I am running the application by going to this URL: (http://localhost:9089/Perfectgaces/faces/index.jsp) seeing only "Hello World !" but no rich text editor from primefaces-3.3.1.jar

Where I am doing the mistake? Thanks a lot
=================
Ok.....I am seeing these two exceptions in console. Any clue?


 
Consider Paul's rocket mass heater.
reply
    Bookmark Topic Watch Topic
  • New Topic