• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Ron McLeod
  • Paul Clapham
  • Bear Bibeault
  • Junilu Lacar
Sheriffs:
  • Jeanne Boyarsky
  • Tim Cooke
  • Henry Wong
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • salvin francis
  • Frits Walraven
Bartenders:
  • Scott Selikoff
  • Piet Souris
  • Carey Brown

Oops.. Link Appears to be broken, getting error on server after updating web.xml (added <listener>)

 
Ranch Hand
Posts: 52
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
hi friends,
I want to use cron in my web-site. I use Cron to call scheduler which will do sms sending task at particular time in a day.I use cron startup class (StartCron.java) i use to call one java file StatCron from my web.xml. So i added

in Web.xml file. This web application is working fine on Local computer. i am using netbeans to run it. But when i upload this code on server. and restart tomcat, and try to access site i get "Ooops.. Link appears to be broken " error from browser.
I am using struts1.3.8, Netbeans 7, and linux hosting server having tomcat7.0.29 install in it.

Please if anybody have any idea about it please replay...
 
Ranch Hand
Posts: 300
Eclipse IDE Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi Vinod,

Which browser are you using? have you tried it on different browser.Clear cahce in the browser and then run.
I am feelings its more related to browser rather then struts.

Regards
Jatan
 
Vinod suryawanshi
Ranch Hand
Posts: 52
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thanks for your reply, jatan bhavsar...
I am using crome and mozilla browsers. But my web-site is not opening on it when i use listener in my web.xml file. When i remove this listener line from web.xml file then my application is working properly.
 
    Bookmark Topic Watch Topic
  • New Topic