Last week, we had the author of TDD for a Shopping Website LiveProject. Friday at 11am Ranch time, Steven Solomon will be hosting a live TDD session just for us. See for the agenda and registration link
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Paul Clapham
  • Ron McLeod
  • Jeanne Boyarsky
  • Tim Cooke
Sheriffs:
  • Liutauras Vilda
  • paul wheaton
  • Henry Wong
Saloon Keepers:
  • Tim Moores
  • Tim Holloway
  • Stephan van Hulst
  • Carey Brown
  • Frits Walraven
Bartenders:
  • Piet Souris
  • Himai Minh

Can not retrieve definition for form bean null on action

 
Greenhorn
Posts: 3
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hello,

I would request a support to solve this problem that seems to be something simple but still have not found the solution.
According to research on the internet form should be getting initialized, but have not found a way to do it in the Action allowing the form to be loaded on the request.
Not sure if this is the real problem.
I'm putting all the files involving the situation, appreciate the cooperation in advance.

File 01 - DocumentoEscaneadoAction.java



File 02 - EnvioDocumentosEscaneadosForm



File 03 - action-mappings.xml



File 04 - form-beans.xml




File 05 - struts-config.xml



File 06 - envioDocumentosEscaneados.jsp




File 07 - Stack-trace

 
Ranch Hand
Posts: 329
Eclipse IDE Oracle Java
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi Gustavo,

Welcome to JavaRanch!!

Since you do not have deployment exception what we can conclude is that Strut's config files are all well formed. Did you try using simple path like below I mean without "processos", I am not sure if it can take two forward slashes. It should be fine for the "forward"[above line 1] but not sure about the "action path"[line 2] The rest of the code looks fine. If this doesn't work could you post "envioDocumentosEscaneados_jsp.java" which would be in your server cache

 
Gustavo Coelho
Greenhorn
Posts: 3
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Thank you very much for your help, Shankar Tanikella, but i'm not longer working on the same project for a while, the company sent me to extinguish another fire. So, i'll might comming back to solve this issue soon, then i'll get back to this point where i already have a north.

Thanks very much, i appreciate the effots.
 
Shankar Tanikella
Ranch Hand
Posts: 329
Eclipse IDE Oracle Java
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator

Gustavo Coelho wrote:... to extinguish another fire


good luck

Keep posting if something challenging comes up even if you solve it in a blink
 
Do not threaten THIS beaver! Not even with this tiny ad:
Free, earth friendly heat - from the CodeRanch trailboss
https://www.kickstarter.com/projects/paulwheaton/free-heat
reply
    Bookmark Topic Watch Topic
  • New Topic