• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Bear Bibeault
  • Ron McLeod
  • Jeanne Boyarsky
  • Paul Clapham
Sheriffs:
  • Tim Cooke
  • Liutauras Vilda
  • Junilu Lacar
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • fred rosenberger
  • salvin francis
Bartenders:
  • Piet Souris
  • Frits Walraven
  • Carey Brown

Jboss AS7 not accessible via internet, (-b 0.0.0.0 does not solve this issue)

 
Greenhorn
Posts: 7
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
This seems to be a pretty big issue for Jboss, as in, I have searched the Internet for the last couple of weeks and found multiple people with this problem.
I am not very knowledgeable when it come to Servers, hosting and the such but when I undertook this project I never thought I would spend this long at this point in the project.
This is a simple jsf project I have deployed.

I have Jboss running on an Amazon instance of windows server 2007.
I am able to access it via local host:8080/name/index.jsf

This produced my webpage as expected.

However If I try to access it externally from <ip adress>:8080/name/index.jsf
I get noting.

I am able to access other content through my port 80 such as text files and other web pages
<ip adress>/textfile.txt
And it works as expected.

So I tried activating standalone.bat -b 0.0.0.0
And still got noting.

Can anyone help me solve this issue, what am I missing.


Here is an example of my standalone.xml

 
author
Posts: 5856
7
Android Eclipse IDE Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
The -b 0.0.0.0 should work. Look for the following:

a) The console log should list various ports that are opened, ensure that the HTTP port specifies 0.0.0.0. Example:

15:56:18,802 INFO [org.apache.coyote.http11.Http11Protocol] (MSC service thread 1-13) Starting Coyote HTTP/1.1 on http--0.0.0.0-8080

b) You can also run "netstat -ab" to list the opened ports, see what it says for port 8080

c) Finally, verify that port 8080 is opened in the Windows firewall.
 
Ranch Hand
Posts: 73
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi Ben,

You can also consider changing your configuration file in the following way.




To



Make sure you have opened port 8080 in your windows firewall
 
Ben Dunne
Greenhorn
Posts: 7
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I have


I ran netstat and got:

Among other ports.

I went to

And turned off my firewall

My Amazon security group looks like this


Any other suggestions?
 
Peter Johnson
author
Posts: 5856
7
Android Eclipse IDE Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hmm, looks like you need to ask an Amazon expert. From what you posted, there wouldn't be any issues if you were running on a physical box or even a VM in a physical box that you have access to. I have no problems running JBoss AS in a VirtualBox VM running Win 2008 R2 on my desktop, or in a VMWare VM in my employer's datacenter.
 
Greenhorn
Posts: 12
Eclipse IDE Oracle Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
The property


should be changed to



in jboss-as-7.X.X.Final\standalone\configuration\standalone.xml
 
Are we home yet? Wait, did we forget the tiny ad?
Thread Boost feature
https://coderanch.com/t/674455/Thread-Boost-feature
    Bookmark Topic Watch Topic
  • New Topic