• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Devaka Cooray
  • Knute Snortum
  • Paul Clapham
  • Tim Cooke
Sheriffs:
  • Liutauras Vilda
  • Jeanne Boyarsky
  • Bear Bibeault
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Ron McLeod
  • Piet Souris
  • Frits Walraven
Bartenders:
  • Ganesh Patekar
  • Tim Holloway
  • salvin francis

Download excel template is not working on WAS6  RSS feed

 
Ranch Hand
Posts: 275
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi All,

I have a functionality to download excel template which is deployed on WAS6. It has 2 JVMs. When request is routed to 1 of the JVMs, the below code works fine and template is getting downloaded.


But when it routing to 2nd node, the download functionality fails. There is no error in logs but its forwarding control to error page.

What could be the reason of failing it on 1 particular node. When i'm running the same code on tomcat server, never faced this issue.

Thanks in Adv.
 
Grishma Dube
Ranch Hand
Posts: 275
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
No Response

Never Mind. I was able to resolve the issue. It was infrastructure issue where 1 .so file was missing on Unix box and POI was using that it seems.

Thanks
 
Rancher
Posts: 42974
76
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
That sounds unlikely - POI does not have (or use) any native libraries.
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!