Win a copy of Testing JavaScript Applications this week in the HTML Pages with CSS and JavaScript forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Bear Bibeault
  • Ron McLeod
  • Jeanne Boyarsky
  • Paul Clapham
Sheriffs:
  • Tim Cooke
  • Liutauras Vilda
  • Junilu Lacar
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • fred rosenberger
  • salvin francis
Bartenders:
  • Piet Souris
  • Frits Walraven
  • Carey Brown

Maven Dependency Search doesn't work!

 
Greenhorn
Posts: 12
Android Tomcat Server Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi guys.
I want to add dependencies to my maven project, using add dependency.
but when I open the window and write something to be searched, nothing happened! do you know what should I do?
why the search doesn't work?


these are my error logs:




and when I want to add the dependency manually, this happens:




 
author
Posts: 5856
7
Android Eclipse IDE Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
That version of ojdbc14 is not in Maven central. Click this link to see which versions are available:
http://central.maven.org/maven2/org/apache/maven/plugins/maven-resources-plugin/2.4.1/

If you need that specific version, you will have to find out which repository contains that version.
 
Shadi Mehrabadi
Greenhorn
Posts: 12
Android Tomcat Server Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thanks Peter.
emmm... How can I run the search?! what's the problem of that?!
when we add dependenies, eclipse goes to .m2 folder and add the dependency that we want to the project. am I right?

I have hibernate-core in my .m2 folder but when I add it's dependency, the error appears:



did anybody have this problem before?

 
Shadi Mehrabadi
Greenhorn
Posts: 12
Android Tomcat Server Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I just realized what's happening.
when we say add this dependency and click save, eclipse search for it and download it and add it to the .m2 folder.
some of libraries aren't in Maven central, as peter said and I should download and add them manually, with a command in CMD

it seems that my internet connection forbid eclipse to connect and download the libraries and update the index and now, everything is working good.
 
Peter Johnson
author
Posts: 5856
7
Android Eclipse IDE Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I have found Eclipse's "Dependency" dialog to be completely unreliable. I usually just browse (or search) Maven Central to find the artifact I want and grab the dependency information from there.
 
First, you drop a couch from the plane, THEN you surf it. Here, take this tiny ad with you:
Thread Boost feature
https://coderanch.com/t/674455/Thread-Boost-feature
    Bookmark Topic Watch Topic
  • New Topic