Is it true that the naming convention for RESTFul controller methods should not be verb based like i wanted my controller methods to be named as
showDocumentType, editDocumentType and listDocumentType, searchDocumentType, addDocumentType
is it true all RESTFul controller method names should be based on HTTP methods as in
getDocumentType, setDocumentType, putDocumentType
How would a new developer make out for what functions are performed by this controller. I wanted my Controller methods to map to functional specification Use-Cases
Please let me know what are best practices and what should be done in my case?