Win a copy of Five Lines of Code this week in the OO, Patterns, UML and Refactoring forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Bear Bibeault
  • Ron McLeod
  • Jeanne Boyarsky
  • Paul Clapham
Sheriffs:
  • Tim Cooke
  • Liutauras Vilda
  • Junilu Lacar
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • fred rosenberger
  • salvin francis
Bartenders:
  • Piet Souris
  • Frits Walraven
  • Carey Brown

1)Spring MVC with JBOSS vs Tomcat, 2) which version of spring mvc

 
Ranch Hand
Posts: 30
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi

I am new to spring. I am trying to create an application using Spring MVC, Now my question is. whether to deploy it in tomcat 7 or in Jboss 7..x. Now my application is going ot be plain and simple. It has some web pages in Jquery, which will take the input process them and then send the final request to another web service. I really do not need to anything with JMS, but do need to connect to mysql database.


Now i tried running a test app in jboss. it is a pain. i am not sure whcih version of MVC to choose. I had mvc 3.0.1, and it did not deploy on the jboss server. It had some classnotfoundExecption:org/jboss/virtual/VirtualFileVisitor error. After lot of search on net.i found that spring mvc 3.0.1 has this issue with jboss 7 and they have recomended to use spring 3.2.x. With 3.2.x i am getting a property souce error. so not very sure which version of MVC to choose.


summary
1) whether to go for Jboss 7 or tomcat 7
2) which version of mVC to choose to run without any errors.

Thanks in advance.
 
Bartender
Posts: 1682
7
Android Mac OS X IntelliJ IDE Spring Linux
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
It should work with all of them, it sounds like you have something misconfigured. Typically I would say use the newest GA release for everything if you have the choice. Make sure you don't mix versions of Spring stuff. All the jars you use should be for the same version whatever that is.
 
    Bookmark Topic Watch Topic
  • New Topic