Win a copy of Svelte and Sapper in Action this week in the JavaScript forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Ron McLeod
  • Paul Clapham
  • Bear Bibeault
  • Junilu Lacar
Sheriffs:
  • Jeanne Boyarsky
  • Tim Cooke
  • Henry Wong
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • salvin francis
  • Frits Walraven
Bartenders:
  • Scott Selikoff
  • Piet Souris
  • Carey Brown

Failed to resolve artifact error but the jar in question is in my local repository

 
Ranch Hand
Posts: 635
1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I have a jar and pom file in my local m2 repository

C:\Users\XXXXX\.m2\repository\com\xxx\cbs\xxx-jcbs-jaxb-customizations\2.0
xxx-jcbs-jaxb-customizations-2.0.jar
xxx-jcbs-jaxb-customizations-2.0.pom.xml

The problem is that mvn cant see the jar and wont resolve the dependancy in my project POM.



I tried to get it to run my local only

mvn -o clean install, it still cannot find the jar in question.

I get the error

Missing com.xxx.cbs:xxx-jcbs-jaxb-customizations:jar:2.0

Do i need delete the jar an then run


To get maven to acknowledge that the path and jar exists.

Is there another way. since i have no idea what to put -Dfile=/path/to/file -Durl=[url] -DrepositoryId=[id]
And dont wnat to spend a whole afternoon trialing and erroring.
 
Tony Evans
Ranch Hand
Posts: 635
1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Ignore this problem, for some reason my profile became a roaming profile and was pointing at a different repository.
 
Don't get me started about those stupid light bulbs.
    Bookmark Topic Watch Topic
  • New Topic