• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Paul Clapham
  • Bear Bibeault
  • Liutauras Vilda
  • Devaka Cooray
Sheriffs:
  • Knute Snortum
  • Junilu Lacar
  • Henry Wong
Saloon Keepers:
  • Ron McLeod
  • Stephan van Hulst
  • Tim Moores
  • Carey Brown
  • Tim Holloway
Bartenders:
  • salvin francis
  • Frits Walraven
  • Piet Souris

Eclispe Classes not created in classses

 
Ranch Hand
Posts: 397
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi All,

I am using eclipse and set the build class path to /WEB-INF/classes as default folder.

earlier eclipse was able to generate and save the class files from each packages to classes but currently deleted the all class file from classes and try to re-build the same but class files are not generated to classes path.

what could be the reason on this.

Regards,
Prabhat
 
Bartender
Posts: 11445
19
Android Google Web Toolkit Mac Eclipse IDE Ubuntu Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
What is the project setting for the output directory?
 
Prabhat Ranjan
Ranch Hand
Posts: 397
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
springPaa/WEB-INF/classes

but no classes generates over there.

I have attached the screen shot for the same.
classes_eclipse.png
[Thumbnail for classes_eclipse.png]
 
Prabhat Ranjan
Ranch Hand
Posts: 397
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
this is working now, i did R &D and re-build the project, i can see the files are complied on classes folder.

One more problem , when i hit the action button on submit , it calls servlet and servlet name with URL mapping are configured on web.xml , not sure getting the error 404


http://localhost:8080/WEB-INF/classes/ControllerServlet


HTTP Status 404 -
type Status report
message
description The requested resource is not available.


web.xml servlet are as below -

<servlet>
<servlet-name>s1</servlet-name>
<servlet-class>com.javatpoint.ControllerServlet</servlet-class>
</servlet>
<servlet-mapping>
<servlet-name>s1</servlet-name>
<url-pattern>/ControllerServlet</url-pattern>
</servlet-mapping>


what is the problem that web container doesn't find the ControllerServlet.class from classes folder under the package?
 
Marshal
Posts: 67356
173
Mac Mac OS X IntelliJ IDE jQuery Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

http://localhost:8080/WEB-INF/classes/ControllerServlet


/WEB-INF/classes is wrong. That's where you should have the context path.
 
Prabhat Ranjan
Ranch Hand
Posts: 397
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I have resolved my problem, action context path was in-correct in form.

thanks Bear.

Regards,
Prabhat
 
Story like this gets better after being told a few times. Or maybe it's just a tiny ad:
Sauce Labs - World's Largest Continuous Testing Cloud for Websites and Mobile Apps
https://coderanch.com/t/722574/Sauce-Labs-World-Largest-Continuous
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!