• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Liutauras Vilda
  • Tim Cooke
  • Jeanne Boyarsky
  • Bear Bibeault
Sheriffs:
  • Knute Snortum
  • paul wheaton
  • Devaka Cooray
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Ron McLeod
  • Piet Souris
  • Ganesh Patekar
Bartenders:
  • Tim Holloway
  • Carey Brown
  • salvin francis

EJB:011113 Error: The Message Driven Bean 'INTYMDB(Application: app, EJBComponent: IMDB.jar)

 
Ranch Hand
Posts: 50
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi All,

Im new to weblogic and migrating the application from OC4J to weblogic 11g.

Im getting the below error on deployment of an EJB application using Weblogic 11g. I am doing the deployment through the weblogic console.

An error occurred during activation of changes, please see the log for details.

Message icon - Error Exception preparing module: EJBModule(IMDB.jar) Unable to deploy EJB: INTYMDB from IMDB.jar: [EJB:011113]Error: The Message Driven Bean 'INTYMDB(Application: app, EJBComponent: IMDB.jar)', does not have a message destination configured. The message destination must be set using a message-destination-link, destination-resource-link, destination-jndi-name or a resource-adapter-jndi-name. Message icon -

Error Substituted for missing class [EJB - 11113]Error: The Message Driven Bean 'INTYMDB(Application: app, EJBComponent: IMDB.jar)', does not have a message destination configured. The message destination must be set using a message-destination-link, destination-resource-link, destination-jndi-name or a resource-adapter-jndi-name.



i have orion-ejb-jar.xml with the previous configurations and now im migrating to Weblogic 11g server. Hence i dont have a tag in orion-ejb-jar.xml as message-driven-descriptor.

my Orion-ejb-jar.xml:

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE orion-ejb-jar PUBLIC "-//ORACLE//DTD OC4J Enterprise JavaBeans runtime 9.04//EN" "xmlns.oracle.com/ias/dtds/orion-ejb-jar-9_04.dtd">;
<orion-ejb-jar>
<enterprise-beans>
<message-driven-deployment name="UPDMDB" connection-factory-location="java:comp/resource/Simulator/SGWD01" destination-location="java:comp/resource/Simulator/UPD.RPLY.Q001" listener-threads="2" dequeue-retry-count="3" transaction-timeout="30" />
</enterprise-beans>
</orion-ejb-jar>



Thanks in advance.
 
Ranch Hand
Posts: 353
2
Eclipse IDE Firefox Browser Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
You need to use WLS proprietary Deployment Descriptor: http://docs.oracle.com/cd/E23943_01/web.1111/e13719/ejb_jar_ref.htm

Please convert Orion DD to WLS, you might use Smartupgrade for this task.
http://www.oracle.com/technetwork/middleware/downloads/smartupgrade-085160.html

Cheers,

Germán
 
Tarik Ansari
Ranch Hand
Posts: 50
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi German,

Is there a way to convert or regenerate the exisiting Orion DD to weblogic 11g WLS ?

Smartupdate helps us to just run the version with the latest one.

Thanks
 
German Gonzalez-Morris
Ranch Hand
Posts: 353
2
Eclipse IDE Firefox Browser Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
use older versions, such as:

WebLogic SmartUpgrade 11g Release 1 (11.1.2.1.0) works with any version of JDeveloper 11.1.1.X (11gR1).

WebLogic SmartUpgrade 11g Release 1 (11.1.3.1.0) works with any version of JDeveloper 11.1.2.x (11gR2).

 
I am a man of mystery. Mostly because of this tiny ad:
Java file APIs (DOC, XLS, PDF, and many more)
https://products.aspose.com/total/java
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!