Win a copy of Rust Web Development this week in the Other Languages forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Tim Cooke
  • Campbell Ritchie
  • Ron McLeod
  • Liutauras Vilda
  • Jeanne Boyarsky
Sheriffs:
  • Junilu Lacar
  • Rob Spoor
  • Paul Clapham
Saloon Keepers:
  • Tim Holloway
  • Tim Moores
  • Jesse Silverman
  • Stephan van Hulst
  • Carey Brown
Bartenders:
  • Al Hobbs
  • Piet Souris
  • Frits Walraven

Is there any compatibility issue between Jasper reports 5.5 jars and Tomcat 6 version

 
Ranch Hand
Posts: 83
Hibernate Spring Java
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hello Ranchers,

We are planning to create reports using latest version of jasper reports(http://community.jaspersoft.com/project/jasperreports-library/releases). Currently we are using Apache-Tomcat 6.6.20. We are not sure that is there any compatibility issue between latest version of jasper reports jars and Apache-tomcat versions?

I have searched for this. Unable to find any concrete information regarding this.

Thanks,
 
Rancher
Posts: 43027
76
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
What is the minimally required servlet/JSP API version Jasper requires? If your Tomcat version satisfies that you should be good to go (unless there is something to this question you haven't mentioned).
 
jagrutkumar dalwadi
Ranch Hand
Posts: 83
Hibernate Spring Java
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I am not sure that what is the minimally required servlet/JSP API version that Jasper requires.
 
Ulf Dittmer
Rancher
Posts: 43027
76
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Actually, since you're using the Library (not the Server), the servlet version is irrelevant; sorry about that. It took me less than a minute to find the documentation page that mentions the requirements of the Library - it is two mouse clicks away from the page you linked to.
 
Ranch Hand
Posts: 421
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hello I am writing upon this subject because I am using Apache Tomcat 6.0_39 and Jasper Reports 5.5. I noticed that the .jars for Jasper do not go in the lib folder of the web project, that the Apache Tomcat lib folder contains two Jasper jars. Even though I removed all the jars from the web app, I am still getting errors. I need to get the Jasper reports to run on the localhost server and it is generating this error consistently:

 
WHAT is your favorite color? Blue, no yellow, ahhhhhhh! Tiny ad:
Building a Better World in your Backyard by Paul Wheaton and Shawn Klassen-Koop
https://coderanch.com/wiki/718759/books/Building-World-Backyard-Paul-Wheaton
reply
    Bookmark Topic Watch Topic
  • New Topic