• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Ron McLeod
  • Paul Clapham
  • Bear Bibeault
  • Junilu Lacar
Sheriffs:
  • Jeanne Boyarsky
  • Tim Cooke
  • Henry Wong
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • salvin francis
  • Frits Walraven
Bartenders:
  • Scott Selikoff
  • Piet Souris
  • Carey Brown

Struts 2 and Linux

 
Ranch Hand
Posts: 39
PHP Tomcat Server Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I want to know why my struts 2 appliaction is not working on linux.
Please someone answer!!!
 
Sheriff
Posts: 10445
227
IntelliJ IDE Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Welcome to CodeRanch!

What do you mean it's not working? Please add as much details as possible for someone to be able to help.
 
Saumitra Tiwari
Ranch Hand
Posts: 39
PHP Tomcat Server Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
My app is running correctly on windows but when I am running war file on linux it seems like that file is not recognized by server.
Nothing shows in error log or server log!!!
what I am missing that I want know...
 
Bartender
Posts: 9615
16
Mac OS X Linux Windows
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

Jaikiran Pai wrote:
What do you mean it's not working? Please add as much details as possible for someone to be able to help.



What he said. You are still leaving out critical details. What server are you using? Have you verified that the server is running? How are you deploying the WAR? How experienced are you with Unix-like OS's?
 
Saumitra Tiwari
Ranch Hand
Posts: 39
PHP Tomcat Server Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
not much experience with linux, current red hat linux version 5.4, I simply copy war file in tomcat webapps folder then it automatically deploys, tomcat version 6 on server and my server is running correctly because all struts 1 application are working correctly...
Any thing else needed please ask...
Thanks for replying....
And please do reply....
 
Jaikiran Pai
Sheriff
Posts: 10445
227
IntelliJ IDE Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

Any thing else needed please ask...



My app is running correctly on windows but when I am running war file on linux it seems like that file is not recognized by server.



Why exactly do you think the application isn't recognized by the server? Are you accessing some URL to test the application? What exact URL is it? From which system are you accessing that URL from - same as the server or some other machine? What result do you see when you access that URL? Does the catalina.out show that the application was picked up for deployment?
 
Saumitra Tiwari
Ranch Hand
Posts: 39
PHP Tomcat Server Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I am calling the application via its folder name as it is in webapps folder created automatically by war file. When I access the app then its show 404 error , if I access jsp page then also it says 404 and I am running app within the server. What I am thinking is that something is wrong with struts.xml or wed.xml

web.xml
----------------------------------------------------

--------------------------------------------------------
struts.xml
--------------------------------------------------------

-----------------------------------------------------
example.xml
-----------------------------------------------------

----------------------------------------------
these are xml files of a project created by netbeans itself, so I have changed nothing....
 
Joe Ess
Bartender
Posts: 9615
16
Mac OS X Linux Windows
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

Saumitra Tiwari wrote:I am calling the application via its folder name as it is in webapps folder created automatically by war file.



As Jaikiran has asked, do you see log messages that the application has been deployed? Since a folder is being created, I would assume so, but we want to make sure.
Does Tomcat still have the manager application installed? Can you access it and verify installation?
If there were problems in your XML files, I'd expect errors in the Tomcat logs. You say you have a Struts 1 application that works. Is that running on this Tomcat server as well?
Is this server a "production" server? The reason I ask is that your server administrator may have put some limitations in place (i.e. turning off autodeploy).
 
The happiness of your life depends upon the quality of your thoughts -Marcus Aurelius ... think about this tiny ad:
Building a Better World in your Backyard by Paul Wheaton and Shawn Klassen-Koop
https://coderanch.com/wiki/718759/books/Building-World-Backyard-Paul-Wheaton
    Bookmark Topic Watch Topic
  • New Topic