Win a copy of TDD for a Shopping Website LiveProject this week in the Testing forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Paul Clapham
  • Ron McLeod
  • Jeanne Boyarsky
  • Tim Cooke
Sheriffs:
  • Liutauras Vilda
  • paul wheaton
  • Henry Wong
Saloon Keepers:
  • Tim Moores
  • Tim Holloway
  • Stephan van Hulst
  • Carey Brown
  • Frits Walraven
Bartenders:
  • Piet Souris
  • Himai Minh

HTTP Status 500 - org.apache.jasper.JasperException: java.lang.NullPointerException: Module 'null'

 
Greenhorn
Posts: 20
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi,

I am suvendu new to struts. I am trying to develop a simple project. but when I run the code there is an error saying

HTTP Status 500 -

--------------------------------------------------------------------------------



My codes are given bellow

StudentAction.java
-----------------------

StudentFrom.java
-----------------------

applicationresources.properties
---------------------------------------

Student.jsp
---------------

success.jsp
--------------------

struts-config.xml
---------------------

web.xml
----------------


apart fromthis I added the jars like

commons-beanutils.jar
commons-chain-1.2.jar
commons-collections-3.2.1.jar
commons-digester.jar
commons-fileupload.jar
commons-lang.jar
commons-logging.jar
commons-validator.jar
iText-2.0.7.jar
jakarta-oro.jar
ojdbc14.jar
servlet-api.jar
struts.jar
struts-core-1.3.5(1).jar
struts-legacy.jar
struts-taglib-1.3.10(1).jar
struts-taglib-1.3.5.jar.zip
weld-servlet-core-1.1.8.Final.jar

but I dont figure out where is actually the problem is...

Can any one help me out for this.
 
Bartender
Posts: 9626
16
Mac OS X Linux Windows
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I added code tags to your post. Please use them. It makes your post easier to read.
We have a FAQ entry about this error. I'm curious to know why you have two different versions of the struts-taglib JAR file.
 
SuvenduSekhar Panda
Greenhorn
Posts: 20
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Still the same problem continues after deleting struts-taglib-1.3.5.jar ...
 
Joe Ess
Bartender
Posts: 9626
16
Mac OS X Linux Windows
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Since you have struts-core-1.3.5.jar, I would assume you deleted the wrong Struts taglib JAR file.
The easiest way to fix dependency issues is to use the WEB-INF/lib directory out of one of the example applications in the Struts distribution. Trying to track one down by deleting and adding JAR files one at a time is an exercise in futility.
 
please buy my thing and then I'll have more money:
Free, earth friendly heat - from the CodeRanch trailboss
https://www.kickstarter.com/projects/paulwheaton/free-heat
reply
    Bookmark Topic Watch Topic
  • New Topic