• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Paul Clapham
  • Ron McLeod
  • Bear Bibeault
  • Liutauras Vilda
Sheriffs:
  • Jeanne Boyarsky
  • Junilu Lacar
  • Henry Wong
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Jj Roberts
  • Tim Holloway
  • Piet Souris
Bartenders:
  • Himai Minh
  • Carey Brown
  • salvin francis

Which Version of Google API should install for Google Maps

 
Ranch Hand
Posts: 674
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi there

This is a refernece post from my previous post
https://coderanch.com/t/638130/Android/Mobile/add-Google-API-android-SDK

I have downloaded an ADT with eclipse from Official android sites.

Now I want to use Google Maps in My android app.
1)Now i want a little clarfication that from where and which Google API I should install.?

2)My target version is Android 19 and which Image of googleAPI(x86 or ARM) should I install?

3)In Android API19 do I need to install SDK-platform(r-3)?


Thanks
SdkImage3.PNG
[Thumbnail for SdkImage3.PNG]
 
Rancher
Posts: 43016
76
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
You should download the image that is appropriate for whichever computer you run the SDK on; in most cases, that'll be x86. You should also install the Intel HAXM package; it speeds up emulation performance quite a bit (provided you're using an x86 image, that is).
 
Kishor Joshi
Ranch Hand
Posts: 674
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thanks ulf

What about Google Play Services listed in Extras folder?
 
Ulf Dittmer
Rancher
Posts: 43016
76
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
What about it? Which of the approaches mentioned in the link I posted in the other topic where you asked about this have you tried?
 
Kishor Joshi
Ranch Hand
Posts: 674
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
ok ulf

You mean I need to download (compatiable google APIs version+Google Play Services) for Using Google Maps in my android application
isn't it?
 
Ulf Dittmer
Rancher
Posts: 43016
76
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Yes, you need the Play Services; that's what the other question you asked yesterday is all about, isn't it?
 
Kishor Joshi
Ranch Hand
Posts: 674
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thanks ulf
 
Can't .... do .... plaid .... So I did this tiny ad instead:
Building a Better World in your Backyard by Paul Wheaton and Shawn Klassen-Koop
https://coderanch.com/wiki/718759/books/Building-World-Backyard-Paul-Wheaton
reply
    Bookmark Topic Watch Topic
  • New Topic