• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
  • Campbell Ritchie
  • Ron McLeod
  • Liutauras Vilda
  • Paul Clapham
  • paul wheaton
  • Tim Cooke
  • Devaka Cooray
  • Rob Spoor
Saloon Keepers:
  • Stephan van Hulst
  • Tim Holloway
  • Tim Moores
  • Carey Brown
  • Mikalai Zaikin

Oracle Driver (ojdbc6.jar) security exception when run on Domino server (it's ok when runnng local)

Ranch Hand
Posts: 275
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hello. If anybody has a minute, I am converting a server based Domino agent which performs SQL against legacy SQL Server (using jtds.jar) to interfacing with Oracle (thin, ojdbc5.jar). I worked out an issue a few days ago which I posted at javaranch.

I went ahead and completed all the recoding locally, added ojdbc6.jar to the agent and the local jvm/lib/ext and it works ok. Now when I try to move it and run this on the server, adding ojdbc6.jar to jvm/lib/ext on the server, I get...

Error while registering Oracle JDBC Diagnosability MBean...java.security.AccessControlException: access Denied (javax.management.MBeanServerPermissioncreateMBeanServer)

The legacy "parallel" agent with the SQL Server driver (jtds.jar) is running fine and has been for years. The agent has security level set to 2 and signer has permissions in the Server document. The policy file looks good with All Permissions and pointing to jvm/lib/ext. Would anybody know what I am missing here and why the server is ok with jtds.jar and not ojdbc6.jar. As I said, I did all development on my local Lotus Notes and it was fine running there.

I've read where there might have been some kind of patches for ojdbc5.jar and ojdbc6.jar but my ojdbc6.jar, when I run java -jar on it says...

Oracle JDBC 4.0 compiled with JDK6

I think this version is after all that patching stuff, and it works ok and interfaces with Oracle with none of this access issue when I run on local Lotus Notes.

Thank you so much for reading.
Ranch Hand
Posts: 1143
Eclipse IDE Oracle Java
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I don't think your Oracle JDBC driver is the latest version since Oracle 11.1 refers to Oracle 11g Release 1 and Oracle 11g Release 2 has been available for a long time now.
Indeed the latest Oracle database is 12c.
The Oracle Web site has a JDBC FAQ page which shows a compatibility matrix between Oracle database version, Oracle JDBC driver version and java version.
Make sure that in your enviornment everything matches.
In other words you need to find out which Oracle database you are using and which java version you are using and then get the suitable JDBC driver.

Good Luck,
I am not a spy. Definitely. Definitely not a spy. Not me. No way. But this tiny ad ...
a bit of art, as a gift, the permaculture playing cards
    Bookmark Topic Watch Topic
  • New Topic