Win a copy of Testing JavaScript Applications this week in the HTML Pages with CSS and JavaScript forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
  • Campbell Ritchie
  • Bear Bibeault
  • Ron McLeod
  • Jeanne Boyarsky
  • Paul Clapham
  • Tim Cooke
  • Liutauras Vilda
  • Junilu Lacar
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • fred rosenberger
  • salvin francis
  • Piet Souris
  • Frits Walraven
  • Carey Brown

webstart doesn't load with several JRE/JDK installed on the computer

Posts: 3
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
The JNLP file is dynamically created on the server.

We use: <java version="1.6+"/> In JNLP file, since code is based on JAVA 6.
The app runs well with all JAVA version greater then 6.
We are now facing problems in some cases when trying to launch this web start app on computer in some universities labs.
We found out that in some cases, when there are several JRE/JDK installed on computers in the lab – the application does not start (that is webstart doesn't load).
(I suspect it is also connected to 64bit JAVA…)

For example – in one lab computers were installed with –
- JDK 7.067 64bit
- JRE 7.067 64bit
- JRE 7.067 32bit
In this configuration the webstart started.
Then the following version were installed on the computer (without removing the previous versions) –
- JDK 8.025 64bit
- JRE 8.025 64bit
- JRE 8.031 32bit
At this point, trying to load the application (with JNLP file) did not work. The webstart did not load.

I found out, with this specific configuration, that removing all JAVA 8 versions or removing all JAVA 7 versions would solve the problem.
Yet, this is not a solution for us since the computer in the lab need to have all the listed JRE+JDK versions installed.

Anyone knows anything regarding this problem?
Why does it happen? How can I set the webstart to load with this kind of configuration?
Posts: 3323
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Are there any error/warning messages?
Have you tried running a basic hello world jnlp deployed application on these machines?
yosi wigman
Posts: 3
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi Tony,
No error messages. Simply the web start doesn't start.
Did not try a hello world jnlp – next time I will encounter this problem I will try.

Several days ago I managed to take control over a computer with this problem.
64 bit windows with:
JDK 8.031 64bit
JRE 8.031 64bit
JRE 8.025 32bit

In the JAVA control panel the 8.025 version was not mentioned on the available java versions.
I applied find and added this version. Then I had to disable and then enable java.
After applying these steps – the JNLP worked.

Could it be that the installation of JRE 8.025 was not performed correctly?
Maybe there are specific user restrictions that prevented this version to go into the list of active JAVAs?
(in the add/remove programs this version is listed)

Tony Docherty
Posts: 3323
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Interesting. Not sure what would cause that type of problem.

Next time you come across this, before fixing it, create an .html file with the following script and load it with a browser on the machine in question. It will give you a list of all versions of Java that appear to be installed and if any are ver 1.6 or greater.

Because those who mind don't matter and those who matter don't mind - Seuss. Tiny ad:
Thread Boost feature
    Bookmark Topic Watch Topic
  • New Topic