• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Ron McLeod
  • Paul Clapham
  • Bear Bibeault
  • Junilu Lacar
Sheriffs:
  • Jeanne Boyarsky
  • Tim Cooke
  • Henry Wong
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • salvin francis
  • Frits Walraven
Bartenders:
  • Scott Selikoff
  • Piet Souris
  • Carey Brown

Upgrading ant 1.6.5 to ant 1.9.4 - Still picking up old ant version ( 1.6.5 )

 
Greenhorn
Posts: 11
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hello All,
We are upgrading our build Ant version from 1.6.5 to 1.9.4.

The following variables are set in my .profile



I am calling ws_ant as follows ( with debug and verbose on)



I am seeing the following output when I run the build

Apache Ant version 1.6.5 compiled on June 2 2005



But when I run

java -jar ant-launcher.jar -version

from /u06/apache-ant-1.9.4/lib , I am seeing the following output

Apache Ant(TM) version 1.9.4 compiled on April 29 2014



I am confused as to why it is picking up old ant version
 
Bartender
Posts: 3225
34
IntelliJ IDE Oracle Spring Chrome Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Is Websphere not using its own version of Ant? And not the one you have provided? Confirm if ws_ant is using its own version of Ant it is shipped with.
 
Rancher
Posts: 2759
32
Eclipse IDE Spring Tomcat Server
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
RUn which ws_ant THis will give you the path to the ws_ant script. Open that script and read it and try to understand what it's doing.
 
Venkat Paspula
Greenhorn
Posts: 11
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Ok.. I figured that Webspehere 8.5 is bundled with ant 1.6.5.Here is the command I used




Now the question is how do I use ant 1.9.4 for non websphere tasks and use ant 1.6.5 websphere tasks.
 
Greenhorn
Posts: 2
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
hi, have you solved this problem?
thanks
 
Marshal
Posts: 70248
282
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Welcome to the Ranch You may have a long wait before you get a reply.
 
Andrea Pis
Greenhorn
Posts: 2
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thanks
 
Oh sure, it's a tiny ad, but under the right circumstances, it gets bigger.
Thread Boost feature
https://coderanch.com/t/674455/Thread-Boost-feature
    Bookmark Topic Watch Topic
  • New Topic