• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Bear Bibeault
  • Ron McLeod
  • Jeanne Boyarsky
  • Paul Clapham
Sheriffs:
  • Tim Cooke
  • Liutauras Vilda
  • Junilu Lacar
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • fred rosenberger
  • salvin francis
Bartenders:
  • Piet Souris
  • Frits Walraven
  • Carey Brown

Set WebSphere's default application

 
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
So instead of the url http://myserver.com/ returning me

SRVE0255E: A WebGroup/Virtual Host to handle /jsp/index.jsp has not been defined.
SRVE0255E: A WebGroup/Virtual Host to handle myserver.com:80 has not been defined.

I want it to redirect to the application set at http://myserver.com/myapp

It seems to be trying to redirect to /jsp/index.jsp already, I just need to change that url...

I did this in WebLogic but having trouble figuring it out in WebLogic.

I tried setting the Context root of the application I want as default to '/'. Which worked in setting it as homepage -- but it's not precisely what I'm looking for and it broke the application in question (probably due to resources it uses).

There HAS to be a nicer way to set my homepage to redirect to the application... it seems like a gross oversight if there isn't a nice way to set a default, but I can't seem to find it...
 
Bartender
Posts: 1268
39
IBM DB2 Netbeans IDE Spring Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
As far as I know, setting / as context root is the only way to set an application to handle request to a certain website. You may also want to specify an HTML or jsp page in the welcome page list, so the was automatically serves it when you visit, say, www.mysite.com.
No idea what actually may have broken your webapps, nor what you may do to fix it.
 
Don't get me started about those stupid light bulbs.
    Bookmark Topic Watch Topic
  • New Topic