• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Paul Clapham
  • Ron McLeod
  • Jeanne Boyarsky
  • Tim Cooke
Sheriffs:
  • Liutauras Vilda
  • paul wheaton
  • Henry Wong
Saloon Keepers:
  • Tim Moores
  • Tim Holloway
  • Stephan van Hulst
  • Carey Brown
  • Frits Walraven
Bartenders:
  • Piet Souris
  • Himai Minh

Remote Deploy EJB to Weblogic6.0

 
Greenhorn
Posts: 3
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi.
I am using Visual Cafe 4.5 and BEA Weblogic 6.0 and BEA Commerce 3.5. I am using a laptop as a server. (containing all the BEA products + "ddservices.exe" for JDK 1.3). I have created a simple EJB in VC4.5, but I am unable to deploy correctly to the server. The 'jar' file is created successfully, but when "delivering to server", I get an error message. I have mapped the drives on the server to my "client" so the connection is there, but i get a 'nullpointer exception' every time I try to deploy.
Anybody out there with a possible solution?
Regards
Frode Johansen
 
Frode Johansen
Greenhorn
Posts: 3
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hello again.
I choose to answer my own question (funny, is it not?) :
The trick is to set the IP address of the host to be 127.0.0.1,
and NOT the IP of the computer you actually want to deploy to!!
Confused? Well...so was I. Because you (or at least I) mapped a connection to the remote server FROM the local server, you have to use the IP of the local machine. And that would be 127.0.0.1.
This works for me. No problems.
Next case is distributed debugging....and clustering if I get around to it. :-)
- Frode Johansen -
 
Frode Johansen
Greenhorn
Posts: 3
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
And just to clear things up :
When I said : set the IP to 127.0.0.1, I was of course referring to the "Project" settings in Visual Cafe.
All settings for deploying can be found under the
"Project--> Options --> Server --> Manage Deployment Target" button in Visual Cafe.
In case you were wondering.
- F -
 
Greenhorn
Posts: 2
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hello frode,
I am having the same problem, and I do have it set to 127.0.0.1, but I am still getting the same problem, and I assume that is because I don't have the ddservices.exe running.
How do I get the ddservices running? Is this something that comes with VC?
(containing all the BEA products + "ddservices.exe" for JDK 1.3).

Thank you,
LaloCeli
 
And tomorrow is the circus! We can go to the circus! I love the circus! We can take this tiny ad:
free, earth-friendly heat - a kickstarter for putting coin in your pocket while saving the earth
https://coderanch.com/t/751654/free-earth-friendly-heat-kickstarter
reply
    Bookmark Topic Watch Topic
  • New Topic