Win a copy of Testing JavaScript Applications this week in the HTML Pages with CSS and JavaScript forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Bear Bibeault
  • Ron McLeod
  • Jeanne Boyarsky
  • Paul Clapham
Sheriffs:
  • Tim Cooke
  • Liutauras Vilda
  • Junilu Lacar
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • fred rosenberger
  • salvin francis
Bartenders:
  • Piet Souris
  • Frits Walraven
  • Carey Brown

Maven Build Error : Missing Dependancy

 
Ranch Hand
Posts: 157
Netbeans IDE Tomcat Server
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,

I am using windows and having issue with maven build. I have multimodule maven project. At the parent POM i got few changes that one new profile is there,
name "local". Under the content module there is pom.xml having profile "autoInstallPackage" to deploy whole project. local profile have some properties regarding with servername,serverport
etc. If i build the maven as :

my build goes successfull, But if I use

my build fail with error message:



"local" profile is as below :


Any Idea how can i solve this.

Thanks
 
Ranch Hand
Posts: 10192
3
Mac PPC Eclipse IDE Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Take a look here:

https://repo.adobe.com/

and here on how to:

https://docs.adobe.com/docs/en/cq/5-6-1/developing/developmenttools/how-to-build-aem-projects-using-apache-maven.html
 
vivek dhiman
Ranch Hand
Posts: 157
Netbeans IDE Tomcat Server
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Yeah, I have same in settings.xml and project already building if not using profile "local" and using args. I am looking for what is the issue with "local" profile while getting those args from pom.xml. If this is the dependency issue then it should had to fail in last attempt. Also if we go as per the logs maven try to look this dependancy from https://repo.maven.apache.org/maven2 which is central maven repo (not in project pom), this dependancy is on https://repo.adobe.com/nexus/content/groups/public (which is in project pom)



Thanks,Vivek
 
vivek dhiman
Ranch Hand
Posts: 157
Netbeans IDE Tomcat Server
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Issue solved, added the repository and mirror in %M@_HOME%/conf
 
    Bookmark Topic Watch Topic
  • New Topic