• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Paul Clapham
  • Ron McLeod
  • paul wheaton
  • Devaka Cooray
Sheriffs:
  • Jeanne Boyarsky
  • Tim Cooke
  • Liutauras Vilda
Saloon Keepers:
  • Tim Moores
  • Tim Holloway
  • Stephan van Hulst
  • Carey Brown
  • Piet Souris
Bartenders:
  • salvin francis
  • Mikalai Zaikin
  • Himai Minh

Not Support JDBC 2 ?

 
Greenhorn
Posts: 29
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I have this web application running on weblogic 5.1 SP8, with Oracle server 8.1.7.
To use the batch updates feathure of JDBC2.0, I upload the classes12.zip to the server, and changed the startWebLogic.sh to replace the classes111.zip
with classes12.zip in java class path.
But, when my program call the statement.addBatch, it gave the following error:
java.lang.AbstractMethodError: weblogic/jdbc/pool/Statement.addBatch
Seems the jdbc driver doesn't support this method.
To confirm it, I called the driver.getMajorVersion and it returned 1.
Can anyone tell me
how to make the weblogic support the JDBC2.0?
Thanks.
 
I don't like that guy. The tiny ad agrees with me.
Thread Boost feature
https://coderanch.com/t/674455/Thread-Boost-feature
reply
    Bookmark Topic Watch Topic
  • New Topic