Win a copy of AWS Security this week in the Cloud/Virtualization forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Paul Clapham
  • Jeanne Boyarsky
  • Junilu Lacar
  • Henry Wong
Sheriffs:
  • Ron McLeod
  • Devaka Cooray
  • Tim Cooke
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Frits Walraven
  • Tim Holloway
  • Carey Brown
Bartenders:
  • Piet Souris
  • salvin francis
  • fred rosenberger

forbidden ear deploy wildfly 10

 
Greenhorn
Posts: 3
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hello everyone.
I was faced with the EAR file deploy wildfly 10 problem. I got an application with ejb module and web module. And all this is under EAR. i got maven to control all plugins and dependencys.

When i packaging my ear project with "mvn package" all good, and project builds successfully. I even copy that ear file to wildfly "10.0.0\standalone\deployments" without any problems. My application deploys with no errors. But when im trying to get on my site, i got Forbidden error.

who can tell me where im wrong?

link on github - https://github.com/aiidko/StaticTime

if someone want, i can copy source to this topic.

Thanks.
 
Sheriff
Posts: 10445
227
IntelliJ IDE Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
A quick look suggests, you might be missing an index.html (the default welcome file for an application). If you want to use StaticTime.jsp as your welcome file (the one which gets rendered when you access the root of the web application), then you'll have to edit the web.xml to include it as the welcome file. Take a look at the web.xml's xsd file to see how to specify that in the web.xml.
 
Andrey Zolotukhin
Greenhorn
Posts: 3
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thanks for uour reply.

I added
" <welcome-file-list>
<welcome-file>StaticTime.jsp</welcome-file>
</welcome-file-list>"
in my web.xml. Then i tryed to launch the app -> forbidden again. Then i added index.html file near StaticTime.jsp. And i still get this error.
 
Andrey Zolotukhin
Greenhorn
Posts: 3
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
A bit additional info, if i run app on server from eclipse, its works fine.
That makes me not understanding this situaution with settings in web.xml.
 
My previous laptop never exploded like that. Read this tiny ad while I sweep up the shards.
Devious Experiments for a Truly Passive Greenhouse!
https://www.kickstarter.com/projects/paulwheaton/greenhouse-1
    Bookmark Topic Watch Topic
  • New Topic