• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Paul Clapham
  • Tim Cooke
  • Jeanne Boyarsky
  • Liutauras Vilda
Sheriffs:
  • Frank Carver
  • Henry Wong
  • Ron McLeod
Saloon Keepers:
  • Tim Moores
  • Frits Walraven
  • Tim Holloway
  • Stephan van Hulst
  • Carey Brown
Bartenders:
  • Al Hobbs
  • Piet Souris
  • Himai Minh

Weblogic Clustering

 
Ranch Hand
Posts: 312
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi,
I am just trying to configure clustering in the Weblogic 7.0 Platform.
For that i have used the following:
As per http://dev2dev.bea.com/wls_tutorial/module_3.htm document,
I have given the following during the configuration
Server-1 localhost 7775 7776(SSL)
Server-2 localhost 8001 8002(SSL)
Server-3 172.24.3.15 8001 8002 ( Different System located in the same place)
AdminServer localhost 7001 7002

I can able to start Server-1 using startManagedWebLogic Server-1 http://localhost:7001 and Server-2 as startManagedWebLogic Server-2
But i cann't able to start Server-3. Please guide me to start the Server-3.
(I have same version weblogic platform in that system and also created a domain with the same name). Also i tried the option of creating Server-3 and started the Server-3 over there.
Thanks & Regards,
M.S.Raman
 
Ranch Hand
Posts: 1871
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi
Any logs or error messages will be helpful.
 
Malli Raman
Ranch Hand
Posts: 312
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator

Originally posted by Rahul Mahindrakar:
Hi
Any logs or error messages will be helpful.


Hi Rahul,
I have attached the logs file details.
I have attached log files for both the options (without starting the Remote Weblogic Server instance --> Server-3 in 172.24.3.13:8001 and after starting the Server-3 in 172.24.3.13
Thanks & Regards,
M.S.Raman
<-----
*************************************************************************
Without starting the remote weblogic server (Server-3)& I cannot connect
http://172.24.3.13:8001/console in the browser
*************************************************************************
D:\BEA\USER_P~1\TESTDO~1>startManagedWeblogic Server-3 http://localhost:7775
D:\BEA\USER_P~1\TESTDO~1>echo off
CLASSPATH=D:\bea\jdk131_03\lib\tools.jar;D:\bea\weblogic700\server\lib\weblogic_
sp.jar;D:\bea\weblogic700\server\lib\weblogic.jar;
PATH=.;D:\bea\weblogic700\server\bin;D:\bea\jdk131_03\bin;f:\oracle\ora81\bin;C:
\PROGRA~1\Oracle\jre\112EBD~1.7\bin;C:\PROGRA~1\COMMON~1\Clarify\bin;C:\WINNT\sy
stem32;C:\WINNT;C:\WINNT\System32\Wbem;Z:.;Y:.;
***************************************************
* To start WebLogic Server, use a username and *
* password assigned to an admin-level user. For *
* server administration, use the WebLogic Server *
* console at http://[hostname]:[port]/console *
***************************************************
D:\BEA\USER_P~1\TESTDO~1>"D:\bea\jdk131_03\bin\java" -hotspot -Xms32m -Xmx200m -
Dweblogic.security.SSL.trustedCAKeyStore=D:\bea\weblogic700\server\lib\cacerts -
Dweblogic.Name="Server-3" -Dbea.home="D:\bea" -Dweblogic.management.username= -D
weblogic.management.password= -Dweblogic.management.server="http://localhost:777
5" -Dweblogic.ProductionModeEnabled= -Djava.security.policy="D:\bea\weblogic700\
server\lib\weblogic.policy" weblogic.Server
<Sep 8, 2003 1:23:43 PM IST> <Info> <Security> <090065> <Getting boot identity f
rom user.>
Enter username to boot WebLogic server:mraman
Enter password to boot WebLogic server:
Starting WebLogic Server...
Connecting to http://localhost:7775...
<Sep 8, 2003 1:23:53 PM IST> <Notice> <Security> <090082> <Security initializing
using realm myrealm.>
<Sep 8, 2003 1:23:53 PM IST> <Notice> <WebLogicServer> <000328> <Starting WebLog
ic Managed Server "Server-3" for domain "TestDomain">
Starting Cluster Service...
<Sep 8, 2003 1:24:00 PM IST> <Notice> <Cluster> <000138> <Listening for announce
ments from cluster mycluster on 237.0.0.1:7777>
<Sep 8, 2003 1:24:00 PM IST> <Notice> <Cluster> <000133> <Waiting to synchronize
with other running members of mycluster>
<Sep 8, 2003 1:24:30 PM IST> <Notice> <Cluster> <000134> <Discovered and synchro
nized with 1 other running members of mycluster>
<Sep 8, 2003 1:24:31 PM IST> <Emergency> <WebLogicServer> <000350> <Unable to cr
eate a server socket on Channel Default for: 172.24.3.13/172.24.3.13, port: 8001
. java.net.BindException: Cannot assign requested address: JVM_Bind Perhaps the
address 172.24.3.13/172.24.3.13 is incorrect or another process is using port 80
01.>
<Sep 8, 2003 1:24:32 PM IST> <Emergency> <Security> <090085> <Server failed to b
ind to any port such that it is not reachable from the console.>
<Sep 8, 2003 1:24:32 PM IST> <Emergency> <WebLogicServer> <000342> <Unable to in
itialize the server: Fatal initialization exception>
***************************************************************************
The WebLogic Server did not start up properly.
Reason: Fatal initialization exception
***************************************************************************
D:\BEA\USER_P~1\TESTDO~1>goto finish
D:\BEA\USER_P~1\TESTDO~1>ENDLOCAL
D:\BEA\USER_P~1\TESTDO~1>ENDLOCAL
D:\BEA\USER_P~1\TESTDO~1>
-->
***************************************************************************
Weblogic Server in 172.24.3.13 is started and i can able to open http://172.24.3.13:8001/console
***************************************************************************
Enter password to boot WebLogic server:
Starting WebLogic Server...
Connecting to http://localhost:7775...
<Sep 8, 2003 1:35:00 PM IST> <Notice> <Security> <090082> <Security initializing
using realm myrealm.>
<Sep 8, 2003 1:35:00 PM IST> <Notice> <WebLogicServer> <000328> <Starting WebLog
ic Managed Server "Server-3" for domain "TestDomain">
Starting Cluster Service...
<Sep 8, 2003 1:35:08 PM IST> <Notice> <Cluster> <000138> <Listening for announce
ments from cluster mycluster on 237.0.0.1:7777>
<Sep 8, 2003 1:35:08 PM IST> <Notice> <Cluster> <000133> <Waiting to synchronize
with other running members of mycluster>
<Sep 8, 2003 1:35:38 PM IST> <Notice> <Cluster> <000134> <Discovered and synchro
nized with 1 other running members of mycluster>
<Sep 8, 2003 1:35:39 PM IST> <Emergency> <WebLogicServer> <000350> <Unable to cr
eate a server socket on Channel Default for: 172.24.3.13/172.24.3.13, port: 8001
. java.net.BindException: Cannot assign requested address: JVM_Bind Perhaps the
address 172.24.3.13/172.24.3.13 is incorrect or another process is using port 80
01.>
<Sep 8, 2003 1:35:40 PM IST> <Emergency> <Security> <090085> <Server failed to b
ind to any port such that it is not reachable from the console.>
<Sep 8, 2003 1:35:40 PM IST> <Emergency> <WebLogicServer> <000342> <Unable to in
itialize the server: Fatal initialization exception>
***************************************************************************
The WebLogic Server did not start up properly.
Reason: Fatal initialization exception
***************************************************************************
 
Ranch Hand
Posts: 166
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Is 172.24.3.15 binded to localhost?
If true, then use different ports than 8001, 8002
 
Malli Raman
Ranch Hand
Posts: 312
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator

Originally posted by Steve Lu:
Is 172.24.3.15 binded to localhost?
If true, then use different ports than 8001, 8002



Sorry Rahul, the problem description and the log file are mismatching. The log file is generated for the following configuration
----------------------------------------------------------------------------
No. Server Name Type hostName/IP Address Port Number/SSL
----------------------------------------------------------------------------
1 AdminServer Admin Server localhost/172.24.3.15 7001/7002

2 Server-1 ManagedServer localhost/172.24.3.15 7005/7006

3Server-2 ManagedServer localhost/172.24.3.15 7009/7010
4 Server-3 ManagedServer 172.24.3.13 8001/8002
----------------------------------------------------------------------------
In this case Server-1 and Server-2 are started and Server-3 is not started and it is located in the different system.
Whether 8001 is specifically assigned for any other purpose in the localhost where admin server is located.
Regards,
M.S.Raman
 
Lasagna is spaghetti flvored cake. Just like this tiny ad:
the value of filler advertising in 2021
https://coderanch.com/t/730886/filler-advertising
reply
    Bookmark Topic Watch Topic
  • New Topic