• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Liutauras Vilda
  • Paul Clapham
  • Bear Bibeault
  • Jeanne Boyarsky
Sheriffs:
  • Ron McLeod
  • Tim Cooke
  • Devaka Cooray
Saloon Keepers:
  • Tim Moores
  • Tim Holloway
  • Jj Roberts
  • Stephan van Hulst
  • Carey Brown
Bartenders:
  • salvin francis
  • Scott Selikoff
  • fred rosenberger

hadoop installation

 
Ranch Hand
Posts: 103
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I download the hadoop code from

https://hadoop.apache.org/docs/r2.6.3/hadoop-project-dist/hadoop-common/SingleCluster.html#Standalone_Operation

After following the instructions and when i run hadoop iam getting the following error
Error: JAVA_HOME is incorrectly set.
Please update D:\hadoop-2.6.3\conf\hadoop-env.cmd


There is no conf folder so i created a config folder and copied this folder D:\hadoop-2.6.3\etc\hadoop to D:\hadoop-2.6.3\conf



In hadoop-env.cmd i have set the java path properly as well as in my local path variable.


Secondly when i googled i found this resource.

http://www.codeproject.com/Articles/757934/Apache-Hadoop-for-Windows-Platform

I have updated java path and other HADOOP_HOME AND JAVA_HOME appropiately



when i did the set as per them also iam getting same error as above.


Then i went here https://sundersinghc.wordpress.com/2013/04/08/running-hadoop-on-cygwin-in-windows-single-node-cluster/ and followed the steps as per them

in cygwin that error is gone.But when i run the command hdfs namenode -format


java.lang.NoClassDefFoundError: org/apache/hadoop/hdfs/server/namenode/NameNode
Caused by: java.lang.ClassNotFoundException: org.apache.hadoop.hdfs.server.namenode.NameNode
at java.net.URLClassLoader$1.run(URLClassLoader.java:202)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)
at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
Could not find the main class: org.apache.hadoop.hdfs.server.namenode.NameNode. Program will exit.
Exception in thread "main"


The class is in this hadoop-hdfs-2.6.3.jar and it's in this path



D:\hadoop-2.6.3\libexec\share\hadoop\hdfs

and if i do hadoop -classpath command i get this

/cygdrive/d/Hadoop-2.3-master/libexec/etc/hadoop:/cygdrive/d/Hadoop-2.3-master/libexec/share/hadoop/common/lib/*:/cygdrive/d/Hadoop-2.3-master/libexec/share/hadoop/common/*:/cygdrive/d/Hadoop-2.3-master/libexec/share/hadoop/hdfs:/cygdrive/d/Hadoop-2.3-master/libexec/share/hadoop/hdfs/lib/*:/cygdrive/d/Hadoop-2.3-master/libexec/share/hadoop/hdfs/*:/cygdrive/d/Hadoop-2.3-master/libexec/share/hadoop/yarn/lib/*:/cygdrive/d/Hadoop-2.3-master/libexec/share/hadoop/yarn/*:/cygdrive/d/Hadoop-2.3-master/libexec/share/hadoop/mapreduce/lib/*:/cygdrive/d/Hadoop-2.3-master/libexec/share/hadoop/mapreduce/*



this jar file is in this folder /cygdrive/d/Hadoop-2.3-master/libexec/share/hadoop/hdfs and /cygdrive/d/Hadoop-2.3-master/libexec/share/hadoop/hdfs/lib/*


Please let me know where iam going wrong.



 
reply
    Bookmark Topic Watch Topic
  • New Topic